It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I've played for 100+ hours just to get stuck on one of the last cutscenes. For some time I've experienced loss of water (just like that it disappeared mid-game) and purple textures (mainly in Novigrad but not limited to) but I tried to ignore that as it wasn't affecting the gameplay. But this... I killed Caranthir and I'm able to swim up to the surface. Then the cut-scene is triggered. No matter what I do it always crashes the game. I tried skipping it, doesn't work. Tried switching to dx11, the game cannot even load correctly. No RT ever. Tried various options for anti-aliasing and plenty of other options. Only three mods installed (each compatible with next gen - missing cards tracker, travel from anywhere, no weight limit). Tried to find a solution somewhere here and in other places to no avail. It would be much less painful if it was after like 5-10 hours of the game but noooo. It had to be in the last 15 minutes (or so). Thanks CDPR for waisting my time and for my frustration. Right now I wasted 10 times more time on finding a solution than it would take me to finish the main storyline.

Anyone who encountered this problem and was able to fix it?

And yes, the game did crash on occasion but it was a nuisance not a pain in the ass like the problem above.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Cause of the crash issue in DX11/DX12 may be:

~ Incorrect user.settings files in the <ur documents>/the Witcher 3 folder (you need to delete all user.settings/dx12user.settings files), or insufficient system privileges to run the game exe or to save game settings files in the documents folder. Running the game exe as an administrator may help with this issue.
~ Outdated or incorrect graphic drivers, lack of directX update:
or visual c++ redistrib update (start install_all.bat as administrator):
no Net. Framework update, XNA framework or windows is not updated.
~ Mods or changes made to game files can cause various problems. The Steam/GOG verify/repair option may not recognize these mods, and even saves can be broken due to some mods used during the game progress. In this case, you may need to run an older save or start a new game. Uninstalling the game does not remove mods from game files, so you have to manually delete the entire game installation folder to ensure that no mods are left behind.
~ Using DVXK dlls may help some users to run DX11: - if ur GPU supports Vulkan technology, then download DXVK dll:
~ If still not working then rollback to 4.01:

- rollback to 4.01 update, for GOG:
- for all platforms:
One of those three mods that are you using may causing this crash issue. First delete all of them and try again.

If problem will be still there then try on DX11 (if it not starting then above is solution for that) or rollback to 4.01 update and try to finish this crashy place quest and after that go back again to 4.02.