It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
pincaviglia86: There is no need to fool with any of those debug mods. If you follow the steps I am about to explain, then you will not now, nor ever need a debug console mod to enable the console. This method is safer, and much more game-friendly, anyway...than putting dll files in your game folder:
Go to MY DOCUMENTS, and open the witcher 3 folder there. This folder is just a place to store user settings, etc. Anyway, in this folder, open the "user" text file and do the following things: (type exactly as indicated)
1. If [General] is not there, then Type [General] at the very top.
2.under that type ConfigVersion=2
3. under that type DBGConsole=true
4. Now select save as....and give the file any name you want (other than "user")
5. Delete the text file file named "user"
6.Rename the file you just saved in step no. 4 above...to this user.settings
That is it...now enjoy the console.
P.S. if you have the debug folder and the dsound dll already in your The Witcher 3\\64\bin folder...it might be a good idea to delete those files as the mod did not work for you anyway.
avatar
olnorton: Thanks for this pincaviglia86, though it appears line 3 should read: DBGConsoleOn=true

Or you could just add the line DBGConsoleOn=true to the general.ini file in The Witcher 3 Wild Hunt\bin\config\base.
Thank you for your Information, DBGConsoleOn=true in the general.ini works fine with v1.30.
The Console Key on a German Keyboard is "ö" on the US Keyboard it is "~"
yep works 100% fine , on US keyboard key you must press is "~"

The debug console is already included in game , a mod is not needed lmao .

Ignore the monkeys that trow with theyr own shiit at you just because they cant figure things out , human nature tend to act like animals , we are animals but some of us can hold this instincts , thats why we are humans . Some ppl on this forum are very stupid and they think they rule the forum topics just because of theyr huge number of posts , even if 90%of the posts are insults and words against gog community in general .
Post edited August 31, 2016 by suciugabriel90
avatar
suciugabriel90: yep works 100% fine , on US keyboard key you must press is "~"

The debug console is already included in game , a mod is not needed lmao .

Ignore the monkeys that trow with theyr own shiit at you just because they cant figure things out , human nature tend to act like animals , we are animals but some of us can hold this instincts , thats why we are humans . Some ppl on this forum are very stupid and they think they rule the forum topics just because of theyr huge number of posts , even if 90%of the posts are insults and words against gog community in general .
Thank you for your kind words and I understand how some folks can misunderstand genuine help for thinking you are putting down their computer knowledge. You are so right that a lot of posts on a forum does not mean you can use profane and abusive language toward someone. It restores my faith in forums to know that people like you and othrrs understand how wrong it is to degrade others whose only intentions were to help out. Thank you again.
avatar
pincaviglia86: people like you and othrrs understand how wrong it is to degrade others
Like patronising others, you mean? Hypocrite.
To add something to this discussion, editing the general.ini as described above does in fact enable the console, and commands work just fine.

However, using this method in conjunction with the Griffin Armor Slim mod (http://www.nexusmods.com/witcher3/mods/439/?) and the Griffin Witcher on the Path recolor (http://www.nexusmods.com/witcher3/mods/1438/?) makes the chest armor totally transparent.

Very odd.
Post edited September 03, 2016 by Sayne
I don't understand the squabble here, I've already praised pincaviglia86 on the Steam forum for a simple and quite intuitive solution to the debug console issue. So I hope the prima donnas here can accept a working fix and get on with their bad selves. I have used several of the popular commands - addmoney, kill, and the like, however many of the useful commands such as "togglelock', CAT(1), etc do not work. Question - is there supposed to be a "library" of batch files somewhere in "bin" or "x64" that are executed by the various commands. If so, where and is it expandable - I can't find it. For instance, I see the script for "kill" was modified at the end to include "togglelock", however the command does not work due to it's location.
Post edited September 10, 2016 by Wildweb
avatar
Hickory: Let me shut you the fuck up (yes, I'm a tad annoyed right now): Don't patronise me. I am fully computer literate, and make my own mods. The entry was inserted in the correct place, in the correct file. Since you say this is information directly from CD Projekt, and that it is a switch for the game engine, then having mods installed will make no difference. I did remove the console enabler mod fully before trying this, but it still does not work. I am running 1.24 on Windows 7 Ultimate.

I will ask you a question: what key is this supposed to enable to get the console open? I tried Tilde, F1-F12, and pretty much all other keys. It does not work.
avatar
pincaviglia86: I have no way of knowing the extent of your computer knowledge. I was going by what little I could get from the other replies from the other posters here. If you want to "shut me up...then I don't have a problem with that. at all. I have been wrong before, and I was wrong here. You obviously don't want any help from me, so you won't get it. If the post bothers you so much, then don't worry....I am going to delete it.. I guess forums ain't what they used to be these days. Usually someone asks for help and people try to reply to the best of "THEIR" knowledge from what "THEY" read in posts. Anyway, it sure as Hell won't be from me, but...for what its worth, I hope you get some sort of solution.
pincaviglia86 et al, In my reply to this matter on Steam, and with a clue from pincaviglia86 that the "user" file is updated when the game is initiated from Steam, I opened the "new" user file after restart and discovered that line 3 "DBGConsoleOn=true" did not get incorporated. So I added the line back into the script and all ran just as advertised. Even if you follow the instructions EXACTLY several times, the last line does not get entered when the file is reset by Steam OR GOG, but once you revise their updated file it remains revised. Good Luck!
avatar
Wildweb: the last line does not get entered when the file is reset by Steam OR GOG, but once you revise their updated file it remains revised.
It is not Steam or GOG that is overwriting your user file, it is the general.ini file in The Witcher 3 Wild Hunt\bin\config\base.
That is why you should make the change there.
avatar
Wildweb: the last line does not get entered when the file is reset by Steam OR GOG, but once you revise their updated file it remains revised.
avatar
olnorton: It is not Steam or GOG that is overwriting your user file, it is the general.ini file in The Witcher 3 Wild Hunt\bin\config\base.
That is why you should make the change there.
You may be right, olnorton, but it does get overwritten AND it leaves out the "DBGConsoleOn=true" line, which needs to be added manually after the first game start following the creation of the new "user" file - right? That's what made my DBGC work smartly. AND, I only followed the previous instruction to modify the "user" file at the base C:/The Witcher 3 folder.
the game keeps reseting the user.settings without the debug code. like removing the code from the user settings so i cant open the console in game. what do i do?
avatar
sfaith05: the game keeps reseting the user.settings without the debug code. like removing the code from the user settings so i cant open the console in game. what do i do?
Don't edit the user settings.

Just add the line DBGConsoleOn=true to the general.ini file in The Witcher 3 Wild Hunt\bin\config\base.

https://www.gog.com/upload/forum/2016/08/8406f001776c21c0749c9053e3436308b24a4167.jpg