It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've been playing the game for the last few months and never noticed an issue with the achievements. But now, no achievement will unlock. The last achievement was unlocked on November 9th.

I know that at least Armed and Dangerous, Fast and Furious, Killed It and Woodland Spirit should have unlocked but nothing happened; I'm using either fast and furious repeating the last race I have to win, or Armed and Dangerous crafting and using the six pieces of the griffin gear.

I tried verifying files, reinstalling the game, reinstalling galaxy, adding all the galaxy exe files to the firewall, running the game as admin but nothing works. Also, I tried executing all the galaxy .exe with admin rights but after booting GOG galaxy, none of the exe files keeps the admin rights option (this only happens with GOG apps, any other windows 10 app maintains the admin property).

Any idea?

Edit: Using Windows 10, GOG Galaxy 2.0.55 and Witcher 3 GOTY

Edit2: I just played Mad Max for a while and I haven't received the corresponding story achievement so I guess this is now a GOG issue (in case a mod want to move this to the right forum)
Post edited November 29, 2022 by code88
No posts in this topic were marked as the solution yet. If you can help, add your reply
I finally found the solution! It seems that for some reason one of the Microsoft Redistributable C++ 20XX libraries got corrupted and after repairing those installations the achievements started to unlock again.

Sadly reinstalling GOG Galaxy doesn´t fix this packages that are clearly needed for it´s correct functionality.