It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
Hi all,

We have uploaded a patch for the Linux version of The Witcher 2. Please download and install this patch at your earliest convenience :)

Changes:

Workaround for AMD Catalyst's broken ARB_texture_storage support. We detect Catalyst and disable this extension, for now. AMD have told us that this will be fixed in their next driver release.

Change to memory management - a much smaller "reserve" section is used, and our heap manager now uses regular mmap() allocations. Limited inhouse testing seems to suggest this is more performant and better with large texture loads.

Thanks and have a nice day :)
Post edited September 08, 2014 by JudasIscariot
Thanks for the patch and news. :)
avatar
JudasIscariot: We have uploaded a patch for the Linux version of The Witcher 2. Please download and install this patch at your earliest convenience :)
Did you just upload it again? Or has the Dragonsphere bug returned? Because it just now showed as updated for me again in my games list, even though I had cleared it about an hour ago. Certainly the "update-flag-on-the-menu-bar-takes-hours-to-clear" bug that was never fixed because "the-site-update-is-just-around-the-corner" is still present even though the site update is finally here.
avatar
JudasIscariot: Thanks and have a nice day :)
Thanks for uploading the patch!

Please ask the release team to keep it that way, or even simply split the base tarball in two parts (game data files and Linux specific release from VP to avoid duplications of files in the base tarball and the patch). That would save huge downloads every time VP will release an updated version.
Post edited September 08, 2014 by shmerl
UPDATE:

It's definitely the Dragonsphere bug.
avatar
Wishbone: UPDATE:

It's definitely the Dragonsphere bug.
It cleared up for me, at least for now it's not shown as updated anymore.

UPDATE: I see it has returned. Dragonsphere déjà vu :)
Post edited September 08, 2014 by shmerl
GOG's staff are really good at making websites. Incessant reminders that a product has been updated surely make up for their lack of update delivery systems!
I didn't notice Linux port was in GOG's library until today. Thanx guys. Have yet to try it as I'm still playing the first one (non-natively of course).
Thanks. Just got rid of steam's DRM.
I would buy from you if you had it available when i bought. :(
avatar
claudiop: Thanks. Just got rid of steam's DRM.
I would buy from you if you had it available when i bought. :(
Check out this: https://secure.gog.com/witcher/backup
It should work for the Steam version key as well.
avatar
claudiop: Thanks. Just got rid of steam's DRM.
I would buy from you if you had it available when i bought. :(
avatar
shmerl: Check out this: https://secure.gog.com/witcher/backup
It should work for the Steam version key as well.
I know, i did it. As i said "just got rid of steam's DRM"
But would preffer much more if i gave the comission to GOG instead of Valve.
It's not that i see Valve as a bad company (they do suport us, A LOT), but DRM is always bad...
Thank you, thank you, thank you! This is great. Although install instructions for the patch would be nice. Not too hard to figure out though. Just unpack and run the start.sh script.
thx
Can someone tell me where to get the patch, and how to install it? Or is the patch included in the .sh for fresh installs?
I'd like to avoid that, since I Have had an older sh from a year ago but if it is the only way, then I guess I gotta do it.
Post edited August 25, 2015 by Dorzalty
Where is this patch? I do not see it on the website.