It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello fellow Linux gamers!

Here you can find informations about ./play.it, a tool building packages for Debian, Arch Linux, Gentoo and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your installers for The Witcher games.
These packages can be installed easily with your favourite packages manager.

Download links and usage instructions can be found on the following pages:
The Witcher
The Witcher 2: Assassins Of Kings
The Witcher 3: Wild Hunt

We hope youʼll enjoy the ease-of-use provided by this tool as much as we enjoy writing and tweaking it ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des informations à propos de ./play.it, un outil construisant des paquets pour Debian, Arch Linux, Gentoo ou nʼimporte quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installateurs pour les jeux The Witcher.
Ces paquets sʼinstallent facilement via votre gestionnaire de paquets habituel.

Les liens de téléchargement et les instructions dʼutilisation se trouvent sur les pages suivantes :
The Witcher
The Witcher 2: Assassins Of Kings
The Witcher 3: Wild Hunt

Nous espérons que vous apprécierez le confort apporté par cet outil autant que nous apprécions lʼécrire et lʼaméliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited September 16, 2020 by vv221
Update

Fix dependencies list
  * Drop dependency on obsolete libtxc-dxtn
  * Add missing dependency on libGL.so.1
Post edited January 20, 2020 by vv221
salut ,j ai pas réussi avec cette méthode ça ma bien crée les 9 fichier deb mais il ne veule pas s installer mint 19.4 ,
avec le lanceur gog j installe dans un disque de 6To avec cette méthode ça remplie mon home de 10go
je ne sais pas si c est normal que ça me créé 9 fichier deb après la commende
$ sh ./play-the-witcher-2.sh
le fichier play-it est vide
il y a une commende pour pouvoir installer les deb dans l emplacement que je veux?
Attachments:
avatar
cortomaltesse77: (…)
Comme le jeu est de très grande taille, et que le format de paquet .deb a une limite de taille (autour de 9Gio), il a fallu qu’on le découpe en plusieurs paquets. À savoir que tu n’as besoin d’installer qu’un seul des paquets dont le nom commence par the-witcher-2-voices selon la langue que tu veux utiliser pour les voix en jeux, justement pour économiser de l’espace de stockage.

Pour installer sous un autre chemin que celui par défaut (/usr/local sur Linux Mint) il faut utiliser l’option --prefix de ./play.it au moment de la génération des paquets. Par exemple, pour construire des paquets qui installeront le jeux sous /home/jeux au lieu de /usr/local :
$ sh ./play-the-witcher-2.sh ~/Téléchargements/the_witcher_2_*.sh --prefix=/home/jeux
Tu peux avoir plus de détails sur cette option avec :
$ sh ./play-the-witcher-2.sh --prefix help
Et tu peux aussi obtenir une aide plus complète, listant les autres options disponibles, avec :
$ sh ./play-the-witcher-2.sh --help
Post edited June 18, 2020 by vv221
re merci du coup la fiche a un peux changer?
je ploque plus a cette étape tout s installe dans le home?

# apt install /chemin/vers/jeu.deb /chemin/vers/jeu-data.deb

apt install /mnt/13242424247/jeux/witcher/jeu data /mnt/13242424247/jeux/witcher/jeu pack1 /mnt/13242424247/jeux/witcher/jeu pack2 /mnt/13242424247/jeux/witcher/jeu release /mnt/13242424247/jeux/witcher/jeu voices fr


j ai installé
sudo apt-get install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libgtk2.0-0:i386 libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libfreetype6:i386 libcurl3:i386 libudev1:i386
et mon jeux cet enfin ouvert

mais vu que avec cette commende je suis passe sur de vielle version de certain programme
curl gnubg kicad libcurl4 libcurlpp0 libopenscap8 python-openscap r-base-core r-cran-lattice r-cran-maxlik r-cran-misctools r-cran-sandwich r-cran-zoo gnubg-data kicad-common libboost-context1.65.1 ce sont désinstaller

du coup j ai kicad et openscap qui ne fonctionne plus il ont besoin de version de paquet plus récente conflit entre les version
avatar
cortomaltesse77: re merci du coup la fiche a un peux changer?
Oui, j’ai essayé d’améliorer un peu la clarté des instructions.
avatar
cortomaltesse77: sudo apt-get install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libgtk2.0-0:i386 libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libfreetype6:i386 libcurl3:i386 libudev1:i386
et mon jeux cet enfin ouvert
Normalement tu n’as pas besoin d’installer de dépendances à la main, les paquets installés via ./play.it gèrent déjà ça automatiquement. En particulier, je ne crois pas que tu aies besoin de libcurl3:i386 qui est une bibliothèque périmée que je te conseille de remplacer par libcurl4:i386.
avatar
cortomaltesse77: mais vu que avec cette commende je suis passe sur de vielle version de certain programme
curl gnubg kicad libcurl4 libcurlpp0 libopenscap8 python-openscap r-base-core r-cran-lattice r-cran-maxlik r-cran-misctools r-cran-sandwich r-cran-zoo gnubg-data kicad-common libboost-context1.65.1 ce sont désinstaller

du coup j ai kicad et openscap qui ne fonctionne plus il ont besoin de version de paquet plus récente conflit entre les version
Je pense que si tu remplaces libcurl3:i386 par libcurl4:i386 tu pourras remettre tes outils en état de fonctionnement. Tu devrais pouvoir rétablir la situation avec ces deux commandes :
sudo apt-get install libcurl4:i386 libcurl3:i386-
sudo apt-get install curl gnubg kicad libcurl4 libcurlpp0 libopenscap8 python-openscap r-base-core r-cran-lattice r-cran-maxlik r-cran-misctools r-cran-sandwich r-cran-zoo gnubg-data kicad-common libboost-context1.65.1
ça doit être le problème ,avec le fichier de gog ?
sans libcurl3 i386 ça fonctionne pas sous mint 19 j ai pas libcurl4:i386 j ai que libcurl4 et si je l installe ça me le désinstalle libcurl3 i386 et inversement
quand je passerai sur mint 20 il faudrait que j arrive a installer mes fichier deb dans le bon dossier avec play it
j ai posé la question au support il mon donner les fichier obsolète a installer même le fichier xbox360 des manette
avatar
cortomaltesse77: sans libcurl3 i386 ça fonctionne pas sous mint 19 j ai pas libcurl4:i386 j ai que libcurl4 et si je l installe ça me le désinstalle libcurl3 i386 et inversement
Il doit y avoir un souci dans la configuration de ta Linux Mint si tu as une version de libcurl en 32-bit, mais une autre en 64-bit. Je risque de ne pas pouvoir dépanner de ce côté, je ne connais pas assez bien Linux Mint pour ça.

Quand tu seras passé sur Linux Mint 20, je t’invite à me faire signe par ici où on pourra probablement t’aider plus efficacement en cas de souci lié à Mint.
Update

The Witcher

• Fix initial setup of registry entries
• Use persistent storage for game settings and key bindings
• Store saved games in persistent paths