It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

Just as the subject line says, the launcher won't/can't connect. It was fine until about 10 minutes ago, it could connect no problem. I registered my game finally, and went to DL the Troll Trouble, but got the "error writing file". So I looked in support and tried the fix here -

After doing that the launcher just doesn't connect anymore, I checked IE, made sure Lan was auto and it can connect to sites. any ideas on what to do?

EDIT: Just to be clear, the launcher says "Connection error. Try again later."
Post edited May 24, 2011 by twistedmelon5
This question / problem has been solved by revialimage
According to the running commentary on the Witcher site, the servers went down again for more prep for the patch (reading the comments within the post).

If you absolutely need to get the DLC installed, I'm sure a few internet searches can find you alternative downloads, murky grey legality aside.
Post edited May 24, 2011 by revial