It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Ive been playing the game for the past few hours. It was released in stores here in NZ this morning and although I had pre ordered on GOG, I coudnt wait any longer :)

Just thought id share my experience with the game though, as some users may run into the same issues I had to start off with.

Just a quick rundown on my config:
Core i7 920 @ 4Ghz
Nvidia Geforce 570
6GB RAM

On first startup of the game under video and language options, I clicked 'Auto detect best settings' which set me to 'High' at 1680x1050'. From the first scene in the game the framerate was so bad it made the game unplayable. I then tried scaling each option back in the advanced video settings, including setting the resolution to the lowest option. Nothing seemed to make a difference...

Turned out it was caused by my video card drivers. Doing a clean install of the official 266.58 Nvidia drivers made a world of difference.

I had read on another post to not install the 3D Vision drivers, I have yet to test if this makes a difference.

I hope this helps those of you that may run in to the same problem :-)
Maybe we can get the opinion of an ATI user with a comparable rig? Seems that Nvidia users may have a bit of trouble as this isnt the first nvidia related post I've seen.
avatar
Jaydius: Turned out it was caused by my video card drivers. Doing a clean install of the official 266.58 Nvidia drivers made a world of difference.
The latest version is 270.something. Did you install the older one on purpose or not?
avatar
Jaydius: Turned out it was caused by my video card drivers. Doing a clean install of the official 266.58 Nvidia drivers made a world of difference.
avatar
MaximKat: The latest version is 270.something. Did you install the older one on purpose or not?
I was on the latest drivers (270.61) Id read on the Nvidia forums that the latest drivers have been causing some pretty serious issues for some users, and that the best option right now is version 266.58.
If anyone is using an ASUS G73JW laptop then I'd be keen to hear how it runs?
Pretty sure our Nvidia drivers haven't been updated since November (ASUS has to modify the drivers themselves?)

I'm not gonna be home from work for ages and be able to test it out on this laptop, but if someone has this rig let me know how it performs.

Thanks