It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Completed the download and game installed OK. Clicking on the Witcher 2 Shortcut, gives me screen from which I can start the game. So far so good but clicking on the "launch game" option fails and gives me a message box telling me to use the launcher to start the game. The shortcut target is "D:\Games\Witcher 2\Launcher.exe" and set to start in "D:\Games\Witcher 2\", which is where the game is installed, IE its not installed into Program Files/Program Files(x86).

My system is WIN 7 Pro (x64), Intel i7 950 (3.1GhZ) 12 GB Mem, nVidia GTX460, so I don't think it's a spec issue with my rig.

Game exe's are included in my AV "Safe Applications" (I'm using Kapersky Pure) but I've also tried with the AV disabled - just in case - it didn't make a difference. Also all exe's are set to run as administrator and Windows XP compatibility.

I don't know if its the cause, but I can't register the game, getting the "A connection with server could not be established" messaged

I've also tried running patcher.exe directly from the install folder, which looks as if it's about to download an Activation Patch, but immeadiately fails with a critical error "Error creating temporary file" message.

Also running Witcher2.exe directly from the installed folder gives me the same "use the launcher" error.

The game installer verified the downloaded files, so I doubt I have a corrupted download, so short of uninstalling/re-installing the game - and I really do not want to install into the default locs (Program Files) as for backup/restore/security/upgrade reasons I prefer to keep my C Drive limited to OS/System files only.

So for now I'm stuck, tried everything I can think of but I can't get the game to launch. Does anyone have any idea of what other steps I can take ?


Update: OK I've fixed this. Problem was my AV which seems to have blocked some of the install scripts. Re-installing the game with my AV disabled resolved the issue. About time developers created installers that worked with AV apps.
Post edited May 18, 2011 by flameweaver
No posts in this topic were marked as the solution yet. If you can help, add your reply