It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi there

I've been having pretty baffling performance issues with the game. In most parts (arena included), it runs at 40-70 FPS at 1080p and high settings but at certain points in the game the framerate suddenly drops to nearly unplayable 15-25. These points include, but are not limited to, the camp outside of Triss' tent in the prologue, the port in Flotsam and, the worst of all (I can only get 8-17 FPS there), inside the tavern in Vergen. I'm pretty sure my computer passes the minimum system requirements (even though the CPU could be better). I am able to run most games including Skyrim and Crysis 2 at full setting (minus AA) with at least 30-60 FPS. Lowering the settings does not help either, I tried 640x480 with everything low and I get the same framerate. All of my hardware drivers are up to date. AA, UberSampling, Vertical sync, SSAO and all the blur-related settings are off, so are CPU-heavy settings like dangling objects and decals. I'm running retail version with Enhanced Edition and 3.2 patch installed.

I've tried custom user.ini files (the game seems to ignore them for one reason or another), I've tried changing the Nvidia settings (no results), I've tried running the game under GameBooster (which closes all the unnecessary background processes - no results), I've been searching the internet for solutions for days with some people having similar problems but no plausible answers turned up besides "turn off Uber-sampling" which is really starting to get on my nerves. Seriously people, I haven't even touched the setting in fear my GPU would explode.

At one point I thought that it's just CPU bottlenecking and that an upgrade would help. If that was the case though, wouldn't lowering the settings help? The CPU DOES meet the minimum requirements (if only by a slim margin) and I've seen people on the internet with intel i7 CPUs complaining about similar problems. As I said, 640x480 with lowest settings produces the same framerate as 1920x1080 medium-high settings.

These are my specs:
AMD Athlon64 X2 5200+; 2.7 GHz Dual-core (Dual-core optimizer installed)
2x2 GB DDR2, 800 Mhz
EVGA GeForce GTX560, 1GB GDDR5 (Driver 301.42)
Win7 Home Premium 32-bit

any ideas?
thanks
As you said, it's likely CPU bottlenecking. Lowing settings can't do much, because it's just a matter of too much data coming in at once.