It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Anyone have any issues installing this? I got the game from, and when I enter Downloadable Content in the launcher, I have the option to download the Troll Trouble DLC. Which I do. Then the little button is I click that but nothing seems to happen. I get a green checkmark next to Troll Trouble, but when I got to the Notice Board in Flotsam, all I get is a notice that I need to go to and register, which I've obviously done already to even download to begin with.

(Of course, trying to go to to make sure I'm registered doesn't work, since the Login/Register buttons are greyed out. Guess the site is down?)

Any ideas?
Try exiting from the game and launcher, then right click on the launcher shortcut and select "run as administrator" - I was having the same problem and that worked for me :)
Tried that, no luck.

Anyone know the specific files to delete to try a fresh download/install of just the DLC?
Be clear. Did you click on it in the main launcher window after it finished downloading and said install, or did you click on Downloadable Content, select it from the menu, and then select Install?

If you did the former, nothing is going to happen. That "install" viewed in the main window is misleading and does nothing.
gah, i'm having the exact same problem. i really don't want to move on and miss out on this quest.