It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have the steam version of the game, but when i want to play the tutorial or the main game.
I can only see my hud, hear all the sounds but the screen is pitch black.

Specs

i7 4710HQ
16gb ram
gtx 860m 2gb ddr5
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
witmoos: I have the steam version of the game, but when i want to play the tutorial or the main game.
I can only see my hud, hear all the sounds but the screen is pitch black.

Specs

i7 4710HQ
16gb ram
gtx 860m 2gb ddr5
A simple, but easily overlooked possibility: make sure the drivers for your video card are up-to-date.
Cheers.
avatar
witmoos: I have the steam version of the game, but when i want to play the tutorial or the main game.
I can only see my hud, hear all the sounds but the screen is pitch black.

Specs

i7 4710HQ
16gb ram
gtx 860m 2gb ddr5
avatar
RivenII: A simple, but easily overlooked possibility: make sure the drivers for your video card are up-to-date.
Cheers.
Thanks for your comment!
Sadly I already updated my drivers to the latest version and it still doesn't work.
avatar
witmoos: ...
i7 4710HQ
16gb ram
gtx 860m 2gb ddr5
I see you're using a laptop. The i7 4710HQ should have an integrated Intel HD Graphics 4600 chip, so you've got two GPUs in your machine.
Try forcing your system to use the gtx 860m with the game. Usually there's an option in the nvidia control panel to manage 3d settings and choose which executable uses which GPU. Add all Witcher executables to the list and assign the gtx 860m. Maybe that helps.

And just to be on the save side, re-install all older components of DirectX9 with this offline installer:
http://www.microsoft.com/en-us/download/details.aspx?id=8109
and then run the DirectX Web installer afterwards:
http://www.microsoft.com/en-us/download/details.aspx?id=35

As you're using the Steam version, this might be interesting for you as well:
http://en.cdprojektred.com/support/game-does-not-start-steam/
Post edited November 04, 2014 by DeMignon
avatar
witmoos: ...
i7 4710HQ
16gb ram
gtx 860m 2gb ddr5
avatar
DeMignon: I see you're using a laptop. The i7 4710HQ should have an integrated Intel HD Graphics 4600 chip, so you've got two GPUs in your machine.
Try forcing your system to use the gtx 860m with the game. Usually there's an option in the nvidia control panel to manage 3d settings and choose which executable uses which GPU. Add all Witcher executables to the list and assign the gtx 860m. Maybe that helps.

And just to be on the save side, re-install all older components of DirectX9 with this offline installer:
http://www.microsoft.com/en-us/download/details.aspx?id=8109
and then run the DirectX Web installer afterwards:
http://www.microsoft.com/en-us/download/details.aspx?id=35

As you're using the Steam version, this might be interesting for you as well:
http://en.cdprojektred.com/support/game-does-not-start-steam/
I re-installed the drivers and i already ran the game with the 860m. I launched steam as admin and did the registry checker from the cdproject site. Still no result i can run the game on my 860m or my intel card and still the black screen.
I Recently also tried to download the gog version and that one still has the same problem.
not trying to be a smart ass here, but i wondered what's your gamma set at? Alternatively, did you try to raise the gamma setting to about 1.5?

I only ask because that looks a whole lot like my game did when i had the gamma down for a different game.

This may not help at all.
avatar
RivenII: A simple, but easily overlooked possibility: make sure the drivers for your video card are up-to-date.
Cheers.
avatar
witmoos: Thanks for your comment!
Sadly I already updated my drivers to the latest version and it still doesn't work.
Did you ever figure out a solution? I have the same issue.

The game worked for me in windows 8.1 and I finally gave in and installed Windows 10 and everything else works just fine except this game. Like Witmoos the game loads, shows the cinematics, main title screen and then loads the game to just the HUD. Everything else is black and there is ambient sound/music but no gameplay even when I hit buttons to try something.

I've tried reinstalling the game, checking to see my drivers are up to date, turning off SLI both in the game settings and disabling it, nothing seems to fix it.

It's a shame because I really wanted to go back to this and play it once I finish Blood and Wine.

Anyone with any suggestions or solutions please let me know. Thanks...

[Intel i7 4470K
32 GB
Nvidia Geforce GTX 1080 x2
Windows 10]
Post edited June 11, 2016 by LockeCole42
Okay guys, the issue is definately brightness and gamma.

Go to the Main menu --- Graphics--- Brightness and Gamma settings should be at value 1 or zero. Set them to 5, thats the default setting. If your value is 5 try to go up to value 10. If the problem still presists I can´t help you.

I hope it helped you all.
Post edited January 29, 2017 by Niktodt1
avatar
Niktodt1: Okay guys, the issue is definately brightness and gamma.

Go to the Main menu --- Graphics--- Brightness and Gamma settings should be at value 1 or zero. Set them to 5, thats the default setting. If your value is 5 try to go up to value 10. If the problem still presists I can´t help you.

I hope it helped you all.
Worked for me.
Thank you