It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Dear Friends

Is there any possibility to disable autosave option?
Best regards.

unfortunately not at the moment you'll have to delete your save files manually in the folder, we'll have to wait for a patch :)