It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Tried the script, got his error:

/home/bignickel/.cache/winetricks/directx9: Permission denied/home/bignickel/.cache/winetricks/directx9/directx_Jun2010_redist.exe: No such file or directory

Cannot write to ‘/home/bignickel/.cache/winetricks/directx9/directx_Jun2010_redist.exe’ (Success).
An error occurred downloading the DirectX9 Jun2010 installer
rm: cannot remove '/home/bignickel/.cache/winetricks/directx9/directx_Jun2010_redist.exe': No such file or directory
FIgured it out: i just had to give myself ownership of winetricks, and give myself permissions to write there. Game installed, and seems to be running as well as it can on this rig.
avatar
bignickel1: Game installed, and seems to be running as well as it can on this rig.
I’m glad this one worked for you ;)

Now I just need to figure out what Adamhm do with this wrapper that I miss with the ./play.it script to understand what I need to tweak. (excluding of course the use of a well tested version of WINE)
For some reason every time I try to do the "bash" command it ends up with an error message saying "ERROR: attempt to invoke icotool failed; please make sure that the icoutils package (or your distro's equivalent) is installed".

Could you perhaps help me with this? I run Debian 9.3 btw
Post edited February 16, 2018 by Fereos847
You need to install the icoutils package - do this as you would for installing any other package from your system's repositories. It might be worth checking to make sure you have the other required dependencies installed too & installing those if needed (wine's dependencies, zenity etc.)
Using this wrapper, I was able to successfully install this in Linux Mint 19.2 without any problems. Being a Linux n00b, I can't thank you enough!

For anyone struggling with this, for the least frustrating experience first create the directory that you want to install the game to, then copy all wrapper and game installation files to that directory. Then run witcher_wine.sh from the terminal so you can monitor the installation process.