It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi,

I'm running a GTX 960M. This game has quite a bit of screen tearing. I've turned on VSYNC in NVidia Control Panel and Also in NVidia Profiler/Inspector. I've messed with a bunch of different settings and frame limiting, but I CANNOT get this game to run without screen tearing.

Any help would be appreciated. I'm on my fifth hour of messing with this, and all I've found on the internet is "turn on VSYNC". This is the first time that turning on or forcing on VSYNC doesn't fix screen tearing.

Thanks again,
NTWHA
Hi,

I've finished the game some days ago, and at the beginning I had the same problem. As I use an AMD GPU I can't exactly tell if forcing V-Sync should work, but at least it did not with AMD. Neither did the frame limiter limit framerates.

But what I experienced is, that extreme screen tearing does only appear in the prologue in Kaer Morhem. As the game went on, I never recognized a screen tearing issue any more. Just play a while and look if it gets better, because trying to force V-Sync was a pain for me which I never got working.
avatar
einmuzi: Hi,

I've finished the game some days ago, and at the beginning I had the same problem. As I use an AMD GPU I can't exactly tell if forcing V-Sync should work, but at least it did not with AMD. Neither did the frame limiter limit framerates.

But what I experienced is, that extreme screen tearing does only appear in the prologue in Kaer Morhem. As the game went on, I never recognized a screen tearing issue any more. Just play a while and look if it gets better, because trying to force V-Sync was a pain for me which I never got working.
Thanks for the quick reply. I'm going to do that and see what happens. Thanks for the heads up.
avatar
einmuzi: Hi,

I've finished the game some days ago, and at the beginning I had the same problem. As I use an AMD GPU I can't exactly tell if forcing V-Sync should work, but at least it did not with AMD. Neither did the frame limiter limit framerates.

But what I experienced is, that extreme screen tearing does only appear in the prologue in Kaer Morhem. As the game went on, I never recognized a screen tearing issue any more. Just play a while and look if it gets better, because trying to force V-Sync was a pain for me which I never got working.
avatar
ntwha: Thanks for the quick reply. I'm going to do that and see what happens. Thanks for the heads up.
Hola guys!

Could you please update us on the result?
avatar
ntwha: Thanks for the quick reply. I'm going to do that and see what happens. Thanks for the heads up.
avatar
willie995: Hola guys!

Could you please update us on the result?
I wasn't involved in the original discussion, but the approach may have been wrong.

The problem is caused when the video information is not in sync with the cycles of the image device. Bit like a line of people trying to pass buckets up a line and one person is out of sync with everyone else. Dropped buckets.

The important point here is, it isn't happening to most users. So it has to be caused by something that those affected have.

The first thing to do is to run it in comparability mode. XP Service pack 3 I suggest.

The next is to ensure that all your drivers are up to date. I know that is an oft said point, most of us do, but it's worth mentioning.

Next make sure you don't have any background programs running, especially those which like to update themselves. Updaters are a terrible nuisance. If you can, turn all off as a matter of routine, even Windows.

Witcher allows for a number of resolutions, Either full screen or windowed. The principal difference is the windowed version treats the game like another application, while the full screen version tends to take over the PC.

It may seem obvious to go for one or the other, but on my PC for example, with all 3 Witcher games, I get intermittent crashing if I try to run Chrome at the same time. Most probably because Chrome has some random routine task which clashes with something in each of the games. But with Witcher especially, I really need to check the Wiki every so often. So I do prefer a windowed version. I turn off Chrome after use. (I really should be looking at another browser)

So look at those. Try full screen. If the problem persists, select a window that gives to a good view of the game.

One of the biggest problems with modern OS, especially the graphics drivers, is they frequently incorporate various accelerators and boosters which don't always work as intended.

Sadly I don't know if you use NVIDIA or made the mistake of buying AMD. I also don't know what sort of PC you are using. If it is recent of old.

Assuming, for the moment, you have NVIDIA. Right click on your desktop and open the NVIDIA Control Panel. Look at the features such as 3D. or multiple monitors? Are you using these and others? If not, turn them off. Better still remove them altogether. (Removing graphics drivers is, unfortunately, not simply a matter of uninstall. You need a special program. MajorGeeks has an excellent one. As if you need a link/

Under the heading. Adjust Image Settings with Preview. Select Use my preference emphasising and try moving the slider toward performance. Not all the way of course, while that will dramatically improve speed, it does affect appearance.

Make sure Stereoscopic 3D isn't on of course.
I discuss vsync in the "Fixes To Common Problems" sticky thread (at the end of the post, scroll down a little):

https://www.gog.com/forum/the_witcher/fixes_to_common_problems/post102

In short, I had to use a small external program called D3DOverrider (comes packaged with RivaTuner) that runs in the system tray and forces vsync. Nothing else worked, including control panel and graphics card options. Note that I'm not sure where to get this from now, as I downloaded it many years ago. But I do occasionally use it again for games that I can't seem to get to force vsync.

Note also that there's another suggestion for vsync at the end of the thread:

https://www.gog.com/forum/the_witcher/fixes_to_common_problems/post102
avatar
Waltorious: I discuss vsync in the "Fixes To Common Problems" sticky thread (at the end of the post, scroll down a little):

https://www.gog.com/forum/the_witcher/fixes_to_common_problems/post102

In short, I had to use a small external program called D3DOverrider (comes packaged with RivaTuner) that runs in the system tray and forces vsync. Nothing else worked, including control panel and graphics card options. Note that I'm not sure where to get this from now, as I downloaded it many years ago. But I do occasionally use it again for games that I can't seem to get to force vsync.

Note also that there's another suggestion for vsync at the end of the thread:

https://www.gog.com/forum/the_witcher/fixes_to_common_problems/post102
Found a download that seems to include the D£DOverrider. It is form MajorGeeks so it's been tested for invasive software extras.

http://www.majorgeeks.com/files/details/riva_tuner.html

A discussion site suggests using Rivatuner 2.24c https://community.pcgamingwiki.com/files/file/84-d3doverrider/

I haven't tried it personally, but I have never had any problems with anything from MajorGeeks,