It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi!
I upgraded from Windows 7 to Windows 10 and I get the "system requirements not met" message when trying to load the game.
I tried making a shortcut of the witcher.exe and adding the line "-dontForceMinReqs" (on properties) but the game won't load. I also have tried emulating hardware tnl caps with 3dAnalyze but nothing seems to work.
Does anyone have any suggestions?
Is a different DirectX version needed or something?

I have an Intel integrated graphics card but it ran perfectly well in Safe mode before upgrading to Windows 10. The game won't load from the Safe Mode shortcut.
Running in compatibility mode doesn't seem to work either?
Post edited October 15, 2015 by maseoo
No posts in this topic were marked as the solution yet. If you can help, add your reply
Not the same problem, but I'm also unable to play after upgrading to Windows 10.

Actually I can't even get past the load screen after starting a new game. It either freezes my computer (requiring a hard reset) or BSODs with a driver-related message. Compatibility mode doesn't help.

A quick search tells me others are having this issue as well and rolling back to a sufficiently old NVIDIA driver helps. I don't want to do that though. Any other ideas?
avatar
WuXeS: Not the same problem, but I'm also unable to play after upgrading to Windows 10.

Actually I can't even get past the load screen after starting a new game. It either freezes my computer (requiring a hard reset) or BSODs with a driver-related message. Compatibility mode doesn't help.

A quick search tells me others are having this issue as well and rolling back to a sufficiently old NVIDIA driver helps. I don't want to do that though. Any other ideas?
Same problem here :(
I have the same issue (won't load saves/start a new game, freezes big time requiring a hard reset). And that is after I managed to get past the sudden 'minimum requirements' message that appeared after upgrading to Win10 and a 'couldn't initialise D3Ddevice' one as well.
Windowed mode and running as admin don't help either.

I guess that if you have a WinXP installation disk, it should be possible to use something like Oracle VirtualBox to run the game in it, but that's just an idea I haven't tested.
@b12moguj, @mustakettu85: are you on NVIDIA Optimus-based laptops by any chance? That would narrow down the issue.

I'm pretty confident that it is indeed a driver issue. Since I doubt any fixed to W1 would be issued at this point, it's probably down to NVIDIA to fix this. And since this game isn't exactly on their priority list...

:/
avatar
WuXeS: @b12moguj, @mustakettu85: are you on NVIDIA Optimus-based laptops by any chance? That would narrow down the issue.

I'm pretty confident that it is indeed a driver issue. Since I doubt any fixed to W1 would be issued at this point, it's probably down to NVIDIA to fix this. And since this game isn't exactly on their priority list...
If Optimus means having an integrated Intel video solution actually connected to the monitor, and an NVIDIA card to handle GPU-intensive stuff, then yes I'm on a laptop like this (Toshiba Satellite S50).

After a sequence of some weird shamanic dancing, I actually managed to get the game to load saves w/o freezing, and it even runs with more or less okay FPS (around 40), but I don't know if it works for everyone or how crash-prone it may be over long playing sessions.

Here's the dance I did:

1. I'm running in windowed mode, so this may be important. Or not. YMMV.
2. I got the latest modded driver from laptopvideo2go. http://www.laptopvideo2go.com/drivers - officially not every driver release will support all the mobile GPUs, but with the modded inf-file, it will.
3. In the registry editor, in this folder
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw
I created a DWORD parameter called EmulationOnly and set it to 0.
4. In the NVIDIA control panel, I set the witcher.exe to use the integrated Intel video. Loaded the game, loaded a save; looks ugly, but works.
5. After exiting, back in the NVIDIA control panel I force the game to use NVIDIA only.

It has been working fine so far over the last couple of days. Even with ReShade SweetFX and ambient occlusion hacked in from a custom NVIDIA Inspector profile. VSync is forced "on", but I'm not sure it matters (simply forcing it before doing the video switching didn't help).

Oh BTW, if you haven't run sfc/ scannow from an elevated command prompt after you upgraded to Win10, I suggest you do. It didn't exactly help with launching TW, but some things got fixed and the system started to be more responsive.

PS:

I forgot to mention restartng Windows after the registry edit.
Post edited October 31, 2015 by mustakettu85
Another thing I forgot which may or may not be important: before the whole shamanic dance thing, I ran the compatibility tool on the witcher.exe which set it to use the Vista SP2 compatibility.