It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I am having this same problem. I read elsewhere online to disable auto-save, and generally the problem resolves. I'm going to try it now...