It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Tried Witcher 2, didn't fall in love, and wanted to play through this again. Hit download and for some reason the downloader started overwriting the files, althought they were exactly the same type I have (2.0.0.12). When that's finally done, I hit the .exe to install, and am told something is borked. Then the winner.... to run the integrity check with the installer.... Yes, the exact file that is fucked should fix itself, then? Great.

Tried to download it again, and with the same result. WTF?

Tried to download the first few files, including the .exe, without the often horribly error-enducing GOG Downloader, but still no luck.

Any ideas?
I would strongly recommend submitting a trouble ticket to GOG support, there are a few threads regarding these issues, here and on The Wtcher 2 subforums, and the best solution seems to be contacting support.

Check if any download manager you may be using is disabled or try downloading through a different browser before submitting a trouble ticket, if you feel like it.
It finally started installing now, so I guess it finally worked. That was after downloading the whole hog THREE times, which totals something like 25GB. Without a 100Mbit line, that would have taken a lifetime.

There are clearly pretty darn big issues with the downloader. I've heard so many people talking about it, and I've now experienced it myself. Strangely enough it has worked well for me on XP, but now on 7 it doesn't work so well, and it's the same on my Win 7 laptop, where it takes half an eternity to do anything with it, and I often have to abort because the computer becomes totally unresponsive for very, very long.