It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I know this has been asked before and I know people suggested workarounds.

I tried the borderless fullscreen fix. It seemed to help at first, but today my PC locked up again despite that when I clicked Exit Game. So, it's not a reliable fix. Alt+tabbing to windows before exiting the game and ending witcher.exe from the task manager is a workaround but last night alt+tab didn't work. I kinda knew it that it was gonna freeze again when alt+tab didn't respond. Either I forgot to keep a random explorer window open before launching the game (so that I could at+tab to it) or that workaround doesn't always work.

In any case, I'd like the devs to look into this. This is not a minor issue. It's making me want not to launch the game at all.

Running on Windows 10 with the latest updates.
CPU: AMD FX4100 3.6Ghz
Ram: Gskill 1600mhz 2x4GB
Disk: Sandisk Extreme 120GB
Graphics: MSI Radon HD6850 1GB
Graphics driver: Crimson 16.2.1
Motherboard: Asus M5A97Evo
Post edited January 09, 2017 by Quantus
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have you tried setting compability mode to Win7? I didn't have this problem on my Win10 machine.
avatar
kachna96: Have you tried setting compability mode to Win7? I didn't have this problem on my Win10 machine.
I've seen some people suggesting it on steam forums. I haven't tested it long enough to take it as a solution yet but if it reduces fps (which I suspect it does) I'd like to avoid it as much as I can.

However, I found this: Someone said on steam forums that unplugging the hdmi cable of his monitor fixed his freezing issue. I tried it just a few minutes ago and it worked! I have no idea how or why that could be a solution though :)
Post edited January 09, 2017 by Quantus
Gonna repost it for easier view:

Unplug your hdmi cable if your PC freezes when you try to exit game. Then plug it back in a few seconds later. It worked for me.
Post edited January 09, 2017 by Quantus
avatar
Quantus: Gonna repost it for easier view:

Unplug your hdmi cable if your PC freezes when you try to exit game. Then plug it back in a few seconds later. It worked for me.
I'll try that next time, thanks!