It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
This one's odd.

I was setting up new keys to control Geralt since I'm far more inclined to use the arrow keys than a WASD key setup. When I clicked on the right shift key while on the options menu, my gauntlet looking cursor disappeared. Couldn't find it until I clicked the right shift key again, but as soon as I stop pressing it, the cursor vanishes again. i had to keep on pressing the shift key in order to be able to click with the cursor and leave the game. I restarted the game, the cursor is visible and as soon as I click on the right shift key it becomes invisible again.

I won't use the right shift key as a key anymore but it's an odd and annoying bug (only happened to me in the menus. Haven't checked what happens in game). I'm using an LX7 cordless logitech keyboard and mouse on a windows XP setup.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I don't know what causes it but I have the same problem. :(
avatar
El_Caz: This one's odd.

I was setting up new keys to control Geralt since I'm far more inclined to use the arrow keys than a WASD key setup. When I clicked on the right shift key while on the options menu, my gauntlet looking cursor disappeared. Couldn't find it until I clicked the right shift key again, but as soon as I stop pressing it, the cursor vanishes again. i had to keep on pressing the shift key in order to be able to click with the cursor and leave the game. I restarted the game, the cursor is visible and as soon as I click on the right shift key it becomes invisible again.

I won't use the right shift key as a key anymore but it's an odd and annoying bug (only happened to me in the menus. Haven't checked what happens in game). I'm using an LX7 cordless logitech keyboard and mouse on a windows XP setup.
Isn't it connected with the camera you chose? Over the shoulder have no cursor visible, unless you have shift pressed.

Edit: Remember that you can easily change the camera by pressing F1 F2 or F3.
Post edited May 14, 2011 by fexen
I'm thinking it has to do with the fact that the shift key is used to move the cursor around and click on icons in game. Something curious about the bug is that if you click shift while in the menus and it disappears, then you move the mouse about and then you click and hold shift, the cursor reappears right in the center of the screen. Doesn't matter where you moved it, it always reappears in the center of the screen.

I'm thinking you just can't remap this key. The moment you click it, you're pretty much using it or something and that makes it unmappable.

My mouse and keyboard have some extra buttons and a little program running in the background that lets me change the buttons and a bunch of other settings. Maybe that has something to do with the bug.
Interesting. I had this problem with my Steam copy before and I noticed it was happening when I opened the Steam overlay immediately when that little window popped up showing the serial key so I could get rid of it. Now I have to be patient and wait to start my game before I get rid of the overlay messages.

This doesn't really help if you don't own the Steam version, it seems, so... sorry. :( Just thought I would let you know you weren't the only one who had that problem where you had to hold shift to see your cursor again. :)
This thread kind of answers my question - I'm having difficulty seeing that teeny little cursor! I now realise it's not always visible in OTS mode (I like OTS mode...) It also answers my question of how the hell I use the HUD when moving the mouse keeps turning Geralt around!

Yes, I know, RTFM, but who ever does that before their first game?

Anyway, to add to the thread theme, is there any way to make the mouse cursor (when visible) bigger? Even when it is visible, it's smaller than I'd like! I keep losing it against a busy background, and missing opponents!
My buddy (who bought the Steam version for $20 yesterday and I told him I'm buying it here for $5 today haha) just called me and asked me about this issue since I'm sort of the local tech support guy among my friends and family.

After reading this forum and others via a Google search, I found a solution for him. Maybe it will for you. It goes a little something like this:

Quit the game; if your invisible mouse can't be navigated to highlight the options you want to quit/save, the Enter key DOES work to confirm the current window (sorry Alt-F4 does not kill the game). Or you could just Alt-Tab, open the Task Manager, and kill the game there, though it's not recommended. Anyway, on to the fix...

Go to your Mouse Options and completely disable all shadows, 3D effects, tracers, etc. to make the mouse completely a vanilla Windows mouse cursor.

This worked like a champ for my pal and I'll remember it if/when the issue arises for me.

Cheers, and BoL!
Post edited May 17, 2011 by Blackflagon
avatar
Blackflagon: Go to your Mouse Options and completely disable all shadows, 3D effects, tracers, etc. to make the mouse completely a vanilla Windows mouse cursor.
Thanks. After reading lot of posts about holding "shift" key (which did not work by the way) - this is the first post that shorted my brain circuits - I remembered that I have "trace mouse pointer" turned on. After disabling this it worked like a charm. Thanks again.
This has me stumped...
I have all my cursor options disabled (shadow, trails), and I'm using the standard cursor.
That does nothing for me.
The SHIFT thing is obviously not the solution here, either (if anything, it makes things worse. Though invisible, I can still use the cursor, usually (guessing where it is from visual feedback).
When I press shift, the cursor seems to lock to the center of the screen.

I can get the cursor if I set the game .exe (\System\witcher.exe) to compatibility mode. Really, any option seems to work. I've currently set it to Windows 8.

BUT, be warned: Maybe this is just me, but I've had the game freeze my whole system (AMD) four times in a row, within the first 10 minutes of playing.
Nothing worked, nothing responded. No key combo, no macro key, not the power button, nothing.
It just kept playing the game music on a frozen screen.

So just in case this is not just me, save your stuff and prepare for a hard reset.

I've just done a fresh install, haven't tested it yet, I came here looking for another fix or work.around.
Fingers crossed, here goes nothing...
Post edited January 27, 2017 by svArtist