It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
wtfuredead: it's 2017 and we still have this problem? cause i do :(

(sry for necroposting)
avatar
olnorton: Well did you try the solution above?
Don't use the web installer if you are on windows 8.1 or 10
Make a new temporary folder on your desktop.
Go here http://www.microsoft.com/en-us/download/details.aspx?id=8109 And download the June 2010 runtimes to the temporary folder .
Disable your antivirus software.
Then scroll down and run DXSETUP.exe (see pic)
When it says, Installation Complete, you can delete the temporary folder, and re-enable your antivirus software.
just installed dx9 from the link above my first post, (then had to disable minimum spec checkout, but that's another story). Works like a charm! (besides casual frame drops into 20')

My antivirus is not that intrusive (avast), but others might interfere with the instalation process.