It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I can't download the installers for The Witcher 1 in the Galaxy client. I'm just getting the "server problem" message.
Tried yesterday and tried today after refreshing my account.
Anyone else having this issue or is it just me?
Post edited October 08, 2017 by ELFswe
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
ELFswe: Anyone else having this issue or is it just me?
It seems to be a backend Galaxy issue:
Galaxy API has issues when trying to get download link using the "downlink" url from product details json.

I'll use Jotun Valhalla Edition as an example because I tested this with the official GOG Galaxy client but the issue is wide spread and affects multiple games
...
This causes the backup feature of the official GOG Galaxy client to fail due to "server error"
Until GOG fixes it you can download via the website, GOG Downloader or third-party downloader.
Post edited October 09, 2017 by Gydion
Oh, ok. I noticed later yesterday that I couldn't download Neighbours From Hell 1+2 either.
But it sounds pretty straightforward that it just has the wrong link.