It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I cant change language. No options to do that.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Game Options tab > "Subtitles" and "Voice-overs".