It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I played to the point of doing the autopsy, didnt visit graveyard yet. Now i encountered two bugs, and cannot progress.

-First, since i accused Kalkstein, i talked to him and he is angry and wont talk to me again. But i need to tell him to come to the swamp tower.

-Second, i cannot enter the cemetery. Gravekeeper told me i need a key from Vincent or Thaler, but vincent doesnt offer any dialog options about it (probably because i couldnt get the clue that the dead guy in tavern had). And Thaler, even though i got at least 2 quest messages that he is no longer a suspect wont give me the key either.

So i cannot take Kalkstein to the swamp tower, and cannot go to the graveyard to expose the main villain. Are there any solutions to fix this, or do i have to restart completely?
This question / problem has been solved by cooper.857image
As far as I know the first problem is solved if you just get out the house, then get in again. As for the other, I don't know. Maybe you overlooked something?
Thanks, but i tried exiting the house and that doesnt work. Even tried different daytimes ;)

For the others, i think i dont have any quests i could do now, so nothing should be left. I fought in the Vincent's warehouse long time ago, have him and Thaler both listed in completed Suspect quests as innocent. Cant ask them for the graveyard permit..
Certain quests cannot be completed until you finish other quests, but if you say there's nothing left then I don't know. Try searching for it on the Internet, maybe you'll find something.
If you do the quest for Coleman at the Hairy Bear, and find out what he is up to, Vincent will let you into the graveyard.
Also make sure to carefully talk to everyone again... sometimes there's a new dialogue option, but you can't access it until you choose an older, greyed-out option first. This threw me for a while when I played, since at first glance it looks like there are no new conversation options, but there actually are. I think it happened for me when talking with Thaler, but I'm not certain.
1. talk to Raymond to the point where he says something about going to the swamp tower, but make sure you have the sephiroths. Dont go, just get to that point in his conversation. Then talk to Kalkstein.
2. have a drinking contest with Thaler, Use the light colored beers- bring plenty; then go through all the options for talking to him again because it can trigger, so you can talk to the gravedigger- assuming you have dwarven liquor in your knapsack for him.
3. How is Llewvarden listed for you? how about Ramsmeat? Perhaps you have a few suspects still lurking around?

This is not a bug. At worst, you might do the autopsy again and get a different result if you need to backtrack.
Thanks to all for your replies, tried everything and finally i was able to progress, although i still cant enter cemetery.

What i needed to do was so simple - get all the sephirots. I had 6 out of the 10, so i thought i needed to finish more of the quests to get the rest. Didnt know that i get 3 of them at once for practically nothing, and the last one is given by Raymond and probably not included in the count.

So since i had open quests like Lost Lamb, 3 brooches for Levarden and entering the cemetery i thought i need to finish them first, should have researched more...

After placing the last sephirot i could talk to kalkstein, and now he and raymond are at the tower and i can progress. Thaler and Vincent still wont give me the cemetery pass but i hope i wont need it or will get it later.
Thanks for the help!
Post edited January 15, 2015 by KubaFKubaF