It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just installed The Technomancer. Try to run the game, either from the desktop icon or the exe in the installation folder.
Cursor changes to running process for a few seconds and then reverts to normal arrow. Task Manager shows the exe running for a few seconds with cpu of 0 and Memory of 7544 K then after a few seconds disappears from Task Manager.. I have tried with and without Administrator and with and without compatibility but it does not run.

PC spec
Intel Core i5-3570K CPU @ 3.40GHz
16.0GB Dual-Channel DDR3 @ 800MHz (11-11-11-28)
2047MB NVIDIA GeForce GTX 960 (ZOTAC International)
Windows 7 Pro, 64-bit
MoBo Gigabyte Technology Co. Ltd. Z77X-UP5 TH-CF (Intel Core i5-3570K CPU @ 3.40GHz)
Direct X 11

Can anyone help ?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Problem solved.
I discovered that I could not play any game with messages like
BioShock Infinite requires that your graphice hardware
be compatible with DirectX 10 or DirectX 11, and have
the DirectX 11 runtime installed.

Alpha blending with D3DFMT_A16B16G16R16F is not supported,
which is required to run this game.

dxdiag showed DirectX 11 installed and ok.

Eventually I discovered that literally between shutting down last night and restarting this
morning the graphics card information from Device Manager stated that the graphics card drivers
could not be found. I reinstalled the drivers and so far it seems ok.