It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I get into the Shed with Amelia and Scott I manage to unlock the locker, get the key, get the map and I know where the keyhole is. BUT the keyhole never, ever becomes active for interaction with the key I have.

And yes, I have exhausted all dialogue options with the other characters and the keyhole just remains silent, no "E" to examine whatsoever.

So I need help, technical help. Any ideas how to unbreak this game?, dev console options?, debug options? I am kind of interested in finishing the game and dont want to drop it for some bug in the main story...
Uh.. I think for me it worked without problems (after I found the hole, that is). The "E" shall be there. I could just suggest the usual "turn it off and on again" kind of things.

What if you exit the shed, and enter again? Exit, wander around, and then return? What if you quit and load the game again? (I guess you've already tried that one over the last two days)

Maybe stand at a little different angle? Closer? Further away?

Are you sure that what you see is the right hole? Without giving any spoilers to others, do you see a funny little picture there?

These are just wild guesses. I am sorry for not knowing anything really useful.