It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey all

I've tried to kill the music using the set-up. Every time I save the settings and return, they've reverted to default music being on.

Any idea how to turn it off? Is there a key I can use in-game?

No posts in this topic were marked as the solution yet. If you can help, add your reply
at the moment, it is bugged so it should only play the one song and then the music stops. So just let that one song play and then it'll stop.

It looks like they're working on that setting at the moment to try and fix it.
Rename the MUSIC folder to something else. Ta-da!
Actually it is not only the music. It also fails to activate coloured mouse cursors.
bouchacha: Rename the MUSIC folder to something else. Ta-da!
Haha omg thanks! I hate the music in the game, it's so annoying
My settlers 3 is current, 2020- , I was driven mad by the music. I got rid of it by going to the MUSIC file and renumbering
each sound file by placing an extra 0 at the end of each OGG file. EG., music 2 becomes music 20, etc.,

I hope this helps. 8'))