It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I can't play Settlers 3 in any Multiplayer mode. Here is what i get:

Multiplayer Game Internet:
When I try to create a player or login, I always get this message:
"Lobby server not found due to network problems."
Firewall is disabled.

Multiplayer Game LAN:
We tried to connect with Hamachi. We were able to see eachothers game, but after joining the game we were both stuck on the lobby.
On the host we still had the message "Status: Waiting for Players" and on client "Status: Searching for open games."
On the host the free place in the lobby is still free. On the client you can't even see the lobby itself, you only have the race-select buttons and a cancel button.

Would be cool if anyone can help me because I bought this game for multiplayer only.
No posts in this topic were marked as the solution yet. If you can help, add your reply
the blubyte internet servers are offline iirc.

network over hamachi is tricky, have you opened the correct ports in your router settings? at least one player has to.

edit: should be these:

3343-3400 UDP IN/OUT
47624 TCP IN/OUT
2300-2400 TCP IN/OUT
2300-2400 UDP IN/OUT
Post edited March 09, 2013 by Oedi
have you tried using gameranger? It picks up my settlers 3, I haven't tried using it, but it might work.
This sucks if I can't get the MP to work, was really looking forward to trying to get my friends into playing it!

Any further ideas would be greatly appreciated!
FYI, i can't seem to get a multiplayer session going on the Internet direct from the game (it says it can't find any sessions), but I've just tried to use gameranger suggested by an earlier poster to start a multiplayer session. There were not enough free players to start my own session, but it seems there were multiplayer games going on already which are working. Maybe with more players we can get more MP sessions working?
avatar
DHR107: This sucks if I can't get the MP to work, was really looking forward to trying to get my friends into playing it!

Any further ideas would be greatly appreciated!
what exactly is your issue?
avatar
DHR107: This sucks if I can't get the MP to work, was really looking forward to trying to get my friends into playing it!

Any further ideas would be greatly appreciated!
avatar
Oedi: what exactly is your issue?
I click the MP and I make a new new login name, and then it simply fails at finding an update. Therefore it doesn't let me log into the MP to play it. Kinda frustrating when GoG is selling it as a "Single player and multiplayer" game.

I tried loading the Settlers3_Multi version but that asks for the serial key when you try to play anything.
avatar
DHR107: I click the MP and I make a new new login name, and then it simply fails at finding an update. Therefore it doesn't let me log into the MP to play it. Kinda frustrating when GoG is selling it as a "Single player and multiplayer" game.

I tried loading the Settlers3_Multi version but that asks for the serial key when you try to play anything.
as I said before, ubisoft took the servers down. the game is 12 and a half years old now, you should consider that. if you wait some time you will see that another pop up comes with the message that it cant connect to the lobby server, because there just isnt one anymore. the lan multiplayer still works, even over hamachi.

(just a side note: you have a serial key in your GoG shelf.)

if you want to play online, there is a program called alternate lobby, "alobby", made by the german community to play over the internet, it works and some people are still online.

http://lobby.siedler3.net/index.php?lan=en

http://www.abload.de/img/alobbynfj82.png

if you only wish to play with your friends, hamachi should suffice.
Post edited March 10, 2013 by Oedi
avatar
DHR107: I click the MP and I make a new new login name, and then it simply fails at finding an update. Therefore it doesn't let me log into the MP to play it. Kinda frustrating when GoG is selling it as a "Single player and multiplayer" game.

I tried loading the Settlers3_Multi version but that asks for the serial key when you try to play anything.
avatar
Oedi: as I said before, ubisoft took the servers down. the game is 12 and a half years old now, you should consider that. if you wait some time you will see that another pop up comes with the message that it cant connect to the lobby server, because there just isnt one anymore. the lan multiplayer still works, even over hamachi.

(just a side note: you have a serial key in your GoG shelf.)

if you want to play online, there is a program called alternate lobby, "alobby", made by the german community to play over the internet, it works and some people are still online.

http://lobby.siedler3.net/index.php?lan=en

http://www.abload.de/img/alobbynfj82.png

if you only wish to play with your friends, hamachi should suffice.
Got a problem with the Alobby. When joining game it asks for my cd... in the gog version :(
avatar
LordChuck: I can't play Settlers 3 in any Multiplayer mode. Here is what i get:

Multiplayer Game LAN:
We tried to connect with Hamachi. We were able to see each others game, but after joining the game we were both stuck on the lobby.
On the host we still had the message "Status: Waiting for Players" and on client "Status: Searching for open games."
On the host the free place in the lobby is still free. On the client you can't even see the lobby itself, you only have the race-select buttons and a cancel button.
I am suffering from the exact same problem except I have 2 winXP(SP3) PCs on the same network! If I launch multiple copies from either PC, I can join my own game. I tested DirectPlay between the systems with dxdiag and was successful. No installed firewalls. I have played the retail version of this game (QotA) with these PCs before.
avatar
LordChuck: I can't play Settlers 3 in any Multiplayer mode. Here is what i get:

Multiplayer Game LAN:
We tried to connect with Hamachi. We were able to see each others game, but after joining the game we were both stuck on the lobby.
On the host we still had the message "Status: Waiting for Players" and on client "Status: Searching for open games."
On the host the free place in the lobby is still free. On the client you can't even see the lobby itself, you only have the race-select buttons and a cancel button.
avatar
LordZargon: I am suffering from the exact same problem except I have 2 winXP(SP3) PCs on the same network! If I launch multiple copies from either PC, I can join my own game. I tested DirectPlay between the systems with dxdiag and was successful. No installed firewalls. I have played the retail version of this game (QotA) with these PCs before.
I had the problem too, and it was in fact a firewall problem (Bitdefender in my case). Is the windows firewall active? As I have my firewall in a suite with antivirus, maybe the antivirus programm is causing the problem. Have you tried turning that of? Same thing for anti-malware.
Forwarding the ports in my router's configuration solved the problem for me. My bro could connect from win7 to my win10 LAN s3 server and vice versa. We were in different countries in Europe at the time. Obviously we used Hamachi. Thanks Oedi.

Again, the ports I forwarded to my machine on the router were:
3343-3400 UDP IN/OUT
47624 TCP IN/OUT
2300-2400 TCP IN/OUT
2300-2400 UDP IN/OUT

I also disabled UPnP, but I don't know whether it was part of the solution.
Post edited October 15, 2016 by phanyx