It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have a problem with the Settlers 2 game. I started with the campaign and reached mission VI. Here at some point of the game I encountered a problem that I am not able to cope with: the newly created roads are no longer occupied by a carrier. This refers both to the mainland and to the islands. The area where such new road is constructed is connected with both HQ and many warehouses. I just appoint a new segment of road but a worker never shows up. I tried destroying such road and creating it again but still the same. Also I tried to save the game and then load it up but this hasn't helped. I would like to continue from where I am at in this mission VI, as I've already conquered one of the opponents...
No posts in this topic were marked as the solution yet. If you can help, add your reply
Is this DOS or Aniv?
Darvond: Is this DOS or Aniv?
The one You get from GOG, it is Gold Edition run under DOSBox.