It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Settlers® 4: Gold Edition, The

Changelog for Internal Update (added 15 August 2018):

- [WIN] added Win10 fixes based on Elisha's DxWrapper
avatar
HypersomniacLive: Settlers® 4: Gold Edition, The

Changelog for Internal Update (added 15 August 2018):

- [WIN] added Win10 fixes based on Elisha's DxWrapper
Anyone checked out what GOG actually did here, did they just throw those wrapper dlls in there or do something else? Just hoping they didn't break Windows XP compatibility.
Post edited August 17, 2018 by Crank9000
Whatever they did, it doesn't work for me (on WIndows 10).

I get a black screen as soon as I actually try to play (I tried tutorial maps). Only with Windows XP compatibility modes "worked", but it is extremely slow (as in 5 frames per second at most). Soo.. another patch please?
avatar
nyrknaqre: Whatever they did, it doesn't work for me (on WIndows 10).

I get a black screen as soon as I actually try to play (I tried tutorial maps). Only with Windows XP compatibility modes "worked", but it is extremely slow (as in 5 frames per second at most). Soo.. another patch please?
It works well here under Windows 10 x64 v1803 (17134.228). In the s4.exe files properties I have the "Disable Fullscreen Optimizations" and the "Run As Administrator" option selected.

Now if someone can make an update so there isn't a 7~ second delay before a video begins and when a video ends... that'd be fantastic.
Post edited August 22, 2018 by Franpa
avatar
Franpa: It works well here under Windows 10 x64 v1803 (17134.228). In the s4.exe files properties I have the "Disable Fullscreen Optimizations" and the "Run As Administrator" option selected.
That.. actually crashed my pc. Like, it had to restart. I didn't even know that could still happen.
avatar
Franpa: It works well here under Windows 10 x64 v1803 (17134.228). In the s4.exe files properties I have the "Disable Fullscreen Optimizations" and the "Run As Administrator" option selected.
avatar
nyrknaqre: That.. actually crashed my pc. Like, it had to restart. I didn't even know that could still happen.
That's indicitave of a hardware or driver issue on your computer that this combination of changes just happens to be prone to triggering.
high rated
Heritage of Kings: The Settlers™

Version: 1.06.0217 v2, Date Published: 17/6/2019
Internal Update (08 July 2019)
- Added Polish localization


Settlers® 3: Ultimate Collection

Version: 1.60 v2, Date Published: 18/6/2019
Updated (8 July 2019)
- added Polish language support


Settlers® 4: Gold Edition, The

Version: 2.50.1516 v2, Date Published: 26/6/2019
Updated (8 July 2019)
- added Polish language support


The Settlers® 2: 10th Anniversary

Version: 11757, Date Published: 10/6/2019
Update (08 July 2019)
- added support for the following languages:
* Polish (text and audio)
* French (text and audio)
* Italian (text only)
* Spanish (text only)


The Settlers® 2: Gold Edition

Version: 1.5.1, Date Published: 17/6/2019
Update (08 July 2019)
- added Polish language support (text)
Post edited July 10, 2019 by Splatsch
How come Settlers 4, 5 (Heritage of Kings) and S2 10th Anniversary are playable in virtually any language except for German?
I'm more surprised how UPlay and even to a degree Steam have the History Editions but GOG still updates the old ones.
The game is still reporting the same issue: graphical interface will not start, game will not start.

?? windows 10 here.
I have a radeon 560 graphics card, with the latest drivers from AMD.. 19.7.2 Previously, I could run the game via DXGL, now it won' work via that route. It has updated to the new patched version, and I am getting the error message. I tried changing the window size in config file to suit my actual screen size, but that didn't do any good...


I figured out why DXGL wasn't working. Instead of hitching it to s4_main.exe, I was hitching it to s4.exe, and it wouldn't work. So I attached it to s4_Main.exe in the EXE folder, and lo and behold, I got it going.
Post edited August 05, 2019 by Metaphyzikal
avatar
Metaphyzikal: The game is still reporting the same issue: graphical interface will not start, game will not start.

?? windows 10 here.
I have a radeon 560 graphics card, with the latest drivers from AMD.. 19.7.2 Previously, I could run the game via DXGL, now it won' work via that route. It has updated to the new patched version, and I am getting the error message. I tried changing the window size in config file to suit my actual screen size, but that didn't do any good...
https://www.gog.com/forum/the_settlers_series/guideto_install_settlers_ivand_getting_the_most_out_of_it/post1