It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The binary depends on this library, but it's not included with the game. Makes it somewhat problematic on distros that don't ship the old version of libpng.
avatar
chungy: snip
Did you report this to GOG support? Your should certainly do so!
avatar
chungy: The binary depends on this library, but it's not included with the game. Makes it somewhat problematic on distros that don't ship the old version of libpng.
Resolved this way on my xubuntu 17.04 machine:

https://packages.ubuntu.com/xenial/amd64/libpng12-0/download