It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Decided to finally try out this game, game launches and I skip the fmvs with esc, I get to a playable section, my mouse feels very laggy and performance is bad.

I looked up the pcgamingwiki page which recommends a certain utility, I downloaded it, put it in the folder with the game, launched it, set the settings like the page said to, got the exact same results with 0 change.

Opened Cougar Setup Utility again, and the option for the 3d renderer reset itself, it's the only setting that seems to reset when I try it out, so my assumption is that that's the issue here. I've tried running the utility in admin, I've tried running the game in admin, neither of which solved my issue at all. For the record, the setting itself immediately resets the moment I hit exit and yes to "save configuration?" Even if I didn't launch the game after hitting exit.

I'm genuinely unsure what to do to fix this here, I've seen footage of the game running at at least 60fps with the mouse cursor not jittering around the screen so I know it should be possible :(

Windows 11 Pro Version 21H2 (OS Build 22000.675)
RX 5700xt
Ryzen 7 5800x
1440p 165hz main display, 1080p 144hz secondary display
32gbs ram

Edit: Checked and updated my graphics drivers. Restarted my PC and checked the utility, it actually set itself as the correct renderer by default and even kept that setting... But the game still runs poorly :(
Post edited June 17, 2022 by Zyad48
No posts in this topic were marked as the solution yet. If you can help, add your reply