It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I tried for hours, but wasn t able to get past that problem with the alcohol. I made it finally exactly like told in a walktrough, but still coudn t go on: No matter what I did: The dialog-option to ask Chris about the shelf didn t appear.

So if this problem occurs consistly, start a new game and make sure to focus on this puzzle. I seems like to much going back and forward does confuse the game.

When you have visited the museum, done everything you can there, gone back to Chris, told him about the problems you encountered, cleaned the bottles, there must appear a new dialog option, in which your able to ask Chris about the shelf.

Maybe this helps saving other players a lot of time.
Post edited May 01, 2022 by schaefchen79
Maybe unrelated but how did you even run the game? I'm on WIn10 64-bit and I can't even get the game to boot. Even tried that Cougar Engine Utility, and no dice