It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Since the Trails in the Sky games worked well in wine I thought I would be adventurous and give this game a shot (yes, I realize it's a totally different engine). It doesn't not work, but there are still some issues and I thought I would see if anyone else here had some thoughts on the subject.

First of all it's a DX11 game so you will need DX11 and I recent version of wine.

You will also need the same library for playing movies that you needed for the TitS games. This is not optional this time. The game will crash when it tries to switch between gameplay and movies without it.

Now here are the issues I'm still having:
1. Occasional graphical glitches. Seems fine most of the time but occasionally it spazzes out.
2. I don't hear any music, though sound effects and voices are fine. Now I'm still in the early portion of the game, but I think there should be music...
3. Menu not displaying in combat. Combat works, but I think initially there should be a menu for selection attack/arts/etc. It's not showing up. You can still do everything but it takes some trial and error to figure out what you're even selecting. Oddly the sub menus (like if you select arts and then need to choose a specific art) are fine, it's just the initial menu that's not displaying.

This is using wine 2.13 on a dedicated prefix. 1 and 3 are annoying but I think I could live with them...2 is a deal breaker for me. Maybe there's just no music in the early part of the game but if there is supposed to be then I want to be hearing it.
Yeah, just tested that on my rig, and the results are similar to yours, except worse.

* It appears that I can live without quartz at the very beginning (at least the intro movie): when the game wants to play a movie, I can hear the music, but cannot see any video (black screen). Otherwise it doesn't seem to crash.
* Using native quartz didn't work for me: I get a crash related to devenum, and if I use native devenum, I've got a crash in quartz anyway.
* I wouldn't call the graphic glitches "occasional". In the first minutes of the game, I could see some character speaking, but his model wasn't there for some time.
* The "missing GUI elements" problem is a dealbreaker to me: you can't see the enemies' life bars, which is a real hindrance to plan battles in the game. In submenus of the main menu, no cursor is shown, which will probably be a major hindrance to setup orbments.
* XBox Gamepad doesn't work properly: button are mapped in a non-sensical manner, and I did not find a way to remap them.
* The sound is very glitchy. No music in battle, the "war/soldier screaming" sound effect of the first sequence is unduly repeated til I enter the first battle in the game.

This makes me fear for the possible sen3 pc port.
I can fix the combat menu issue by enabling CSMT using winecfg. I'm on wine 2.13 staging. CSMT is under the Staging tab of the configuration menu.

I still can't get the background music to play though. Given that music is a big selling point for Trails games, would greatly appreciate if anyone with better luck with the music to share their settings.
simsatellite: I can fix the combat menu issue by enabling CSMT using winecfg. I'm on wine 2.13 staging. CSMT is under the Staging tab of the configuration menu.
I tried this and it works for me too. Thanks.

But like you I'm still stuck on the music. And I really don't want to play this game without music...

[s]Does anyone know what format their music is encoded in? It could possibly be a codec issue seeing how other sound works.[/s]
Nevermind, I checked it myself and it appears to be plain old wav. No way that's a codec issue.
Post edited August 04, 2017 by Kevadu
It's good to know that this game at least starts and more or less playable. Don't know who will get the game first, me or my friend but i'll be able to look into those issues this or next week. I think it will be possible to get music running with the usual directx/windows/media etc. sorcery, just like Street Fighter IV/SFxTK/BlazBlue series etc - those games sometimes have sound/music/video issues which can be fixed by installing some dlls.
If we'll get the game running without major bugs i'll post the instructions.

In the meantime you can file a wine bug report. Sometimes things get fixed in the next version on a major scale. For example - Mortal Kombat XL was borderline unplayable in previous version of wine - heavy spiky polygon syndrome on characters and network desyncs. 2.13 staging arrived and game is simply fully playable.

Nevermind, I checked it myself and it appears to be plain old wav. No way that's a codec issue.
Ok, my friend bought the game, we tried to run it, and surprise - it ran without any problems so far, with sound and music.
Which means that codec/library issue is exactly what you're facing here.
Thunderbringer, can you give us a quick list of what components you have installed and which wine version you're using? This is driving me nuts 'cos I get sounds and voice but as soon as I go beyond the title, the music is gone. Specifically, I am observing the following:

- Opening movie - has music
- Title screen - has music and background noise of the train
- Start a new game or load a save game - has voice, sound effects but no music
- Go back to title screen - opening movie still has music, but when getting to the title screen, music is GONE, but background noise of train is still audible!

I also observed the following bizarre behavior:

- Voice, sound effects and music all DO NOT respond to the in-game volume sliders under options
- However, the opening movie DOES respond to the music slider
- The title screen on the other hand does NOT respond to the music volume slider

If I'm missing codec, I should always lack music, not this weird sometimes on sometimes off behavior. Anyone else observe similar issues? If not, it's probably some strange incompatibilities with my setup...
Yeah, simsatellite, that sounds exactly like the behavior I am getting. I forget to mention that I get music on the title screen, but I do. Just not anywhere else.

And you can literally just go into data/bgm/wav/ under the game's directory and all the music files are right there (free sound track!). They are completely bog standard wav files. It can't be a codec issue. Particularly when the sounds that do play are encoded exactly the same way.
Got home, bought the game, installed, installed codecs and other for video - game runs with music. Maybe it's some, dunno, mixer dll or something. I can try to do this thing tomorrow - make a fresh prefix and get videos running, then check if i'll get music.

So far i've found 2 bugs - first one is not a wine bug - game got incomplete (no configuration options) direct input gamepad support so even if i use koku's xinput library camera rotates etc, Dark Souls bug again. So i'm 100% sure that Dark Souls fix (dinput blocker dll) will help here.
Second - game crashes while saving loading sometimes, but save data isn't damaged, so it's a minor issue and also i'm not sure if it's a wine issue. Other than that game works great for me so far (3h of gameplay),
i can post a list of all dll overrides in wine, directly from registry.
most of them are unrelated but check for anything dsound/MCI related.
Other than that i used Trails in the Sky winehq page for reference but as you can see quartz is set to built-in and everything works fine. Before LAVFilters installation i had a crash after the first boss battle when those cannons fired.

[Software\\Wine\\DllOverrides] 1501893905 6633600

also check for GStreamer plugins.
OK, things are going a lot better with 2.13-staging thanks for the suggestion. The graphical glitches seem mostly resolved, no crash in the intro like it used to be, and the intro video playing normally.

However, nothing changed regarding the music.

I tried using some of your overrides (mainly regarding dsound/streamci), Thunderbringer, I also installed LAVFilters. I don't know what to try next :-(.

Like simsatellite reported, I get music on the title screen, then nothing after loading a save/starting a new game, and still nothing after going back to the title screen from the game menu.

Gamepad is also still a mess.

Well, I'm not in a hurry, I can seriously search solutions to this once I'm done with the 3rd.

PS: I got this message in my wine stderr: "AL lib: (EE) ReleaseThreadCtx: Context 0xf3a59d60 current for thread being destroyed, possible leak!", I wonder if this might be related to the music issue?
Post edited August 09, 2017 by frereselric
I guess i'll try to create a clean prefix and install libraries etc. until game will start working without any issues then post the instructions here and Wine AppDB.

BTW i posted about random crashes when loading/saving or playing videos here - tried to run this game in the copy or main wine prefix with just only difference - wine uses ALSA instead of pulseaudio - well they all gone now.
No issues at all. You may have to disable pulseaudio to prevent sound distortion which is quite easy with script like this:

echo "autospawn=no" >> ~/.pulse/client.conf
pulseaudio --kill
WINEDEBUG=-all WINEPREFIX=/path/to/your/prefix /opt/wine-staging/bin/wine ed8.exe
rm ~/.pulse/client.conf
pulseaudio --start

You can use this script if you don't use any custom pulseaudio client.conf. If you do you'll need to modify it, so it will make a backup copy of config file first then restore it before relaunching pulseaudio server.
OK @Thunderbringer, simple question, are you using the GOG Galaxy client to play Cold Steel, or the standalone installer?

I finished the 3rd, so I wanted to try again playing Cold Steel, and I noticed that the build was updated to 1.0.6430.37816 on GOG, but without a patch for Galaxy-less install.

Since downloading the full game requires a couple of hours with my connection, I decided to switch from my Galaxy-less install to a Galaxy install.

After installing the latest version 1.0.6430.37816 in Galaxy, I noticed two things:

1. The music was now correctly playing everywhere, yay!!! But...
2. The graphics during cutscenes are now missing: I see only black or white screens, with sometimes difficult to see character models. This looks like a problem with lightning I suppose?

This was even worse than at first, BUT Galaxy allows to downgrade the version easily, so I went back to 1.0.6421.30108, and TADAAAM!

1. The music problems are still gone
2. The graphics during cutscenes are present!

So the game is at last playable! Now I just have to find a workaround for my controller to be able to play in perfect conditions :-).

So happy...

@Kevadu, if you're not using Galaxy, I suggest you try using Galaxy, and downgrade the game to 1.0.6421.30108 :-).
frereselric: OK @Thunderbringer, simple question, are you using the GOG Galaxy client to play Cold Steel
How? I'm unable to run it. it always shows crash window related to libcef.
Just tried to get this working under Wine Staging 2.16. I'm also getting the sound issues mentioned earlier, and if I try to do the same setup as Trails in the Sky for the cutscenes, I get a crash due to dereferencing a null pointer.

I'm running in a 32-bit prefix, on Arch Linux. The only library overloads I've set up are the ones required by quartz and amstream.