It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi, I just tried to run this game for the first time today. The videos play fine and the title screen loads up. When I go to tutorial the tutorial plays and the controls all work, but there are no graphics behind all of the tutorial stuff (just solid blue). Presumably the game is 3D and everything is working but the 3D. Even the cursor is loading in and reacting to the building underneath it that I can't see. I can't find anything about this when I search online. Obviously I well exceed all requirements listed on GOG at this point, so if it's a hardware issue it has to be either a basic incompatibility or a hardware failure. Since I haven't had trouble with any other games recently I'm guessing it's not my graphics card going bad or anything. I tried raising and lowering settings within the game and nothing changes. Any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have you tried running it in TnL? Go to the little arrow, click more, than the guild tnl. Or maybe reinstall it. Change the graphicscard, wich you have to select in the beginning.