It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I start the game and try creating a new game after picking the area, difficulty and type of game I can't get past the next screen. All that comes up is to put in a First Name and when I do nothing else shows up.

Has anyone else had a similar problem or know what I need to do to fix this?
This question / problem has been solved by Namurimage
You pressed ENTER after typing your name ?
Yes I've tried every key on the keyboard and it still won't do anything.
Yeah, i did find a couple of old instances of that problem, and [url=]here.

I'm not sure what to suggest. Maybe a remap app to temporarily remap the enter key - not sure if it would do trick though, or maybe plug in a different keyboard, that's probably the easyer way. I also don't know if temporarily changing the regional settings on your keyboard layout could fix that.
Post edited February 17, 2011 by Namur
For some reason my game won't register the Enter key unless I hold the Function key and then hit enter. It works now.

Screen is flickering. Anyone know of a fix?

T&L doesn't flicker, but is missing some graphics.