It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

In the Feeble Files after I tow the sales man back to dave's space bar and do everything I am supposed to do to the bike with the alarm I go to take the tow cable like I am supposed to and the game freezes up on me. I have tried reloading the game with no luck I have tried from an earlier save and still no luck. Currently I am downloading the game onto a different computer hoping that this will fix the issue, but if not I am stuck unless someone has had this problem and knows how to fix it or knows the the debug object number for the tow cable so I can just skip this part entirely.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I am playing the game on a windows 10 pc and just tried moving the save files over to a windows 7 pc with the game on it and it is still doing the same thing. I still have the same question as before does anyone know how to fix this issue, have a save file for directly after taking the tow cable, or know the object id for the debug menu so I can skip this part?