It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

As far I can tell, the feature of creating multiple parties does not work on the GOG version of the game, because it automatically uses the party called "GAME." If you want to create your own party rather than using the default party, it will work as long as you call the party GAME - which replaces the default party. I am not sure if there is a way to restore the default party, but I guess you can always re-install the game if necessary.
Gudadantza: [1] Create yourself a new party (if you haven't already done so) - and remember what name you saved the party under;
[2] Go to the folder where The Dark Heart of Uukrul is installed;
[3] Delete all files with the extension .GMI and .IMG, except 2 files using your party name;
[4] Rename your party files to GAME.GMI and GAME.IMG;
[5] Play game.

You will notice that can now load the game using your party."
Nice, that did the trick.
Same issue. On a mac book.

I pressed save and backup. No in-game text saying "saved", etc. I got skeptical it was actually saving. So, I quit and tried to reload, but it reloaded the default party.

I solved this by moving the Dark Heart of the from /Applications to ~/Documents. And opening the app by running: 'open Dark Heart of the' from the command line.

EDIT: Still giving me issues. But I think I might have fixed it for good by deleting the two GAME.* files and editing the dosbox single conf to include name of party: UURKRUL <PARTYNAME> -V
Post edited February 15, 2022 by menschenfresser