It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have tried both single player and co op campaign on a gamepad(s). In each of them I was able to beat only one level before I totally grew irritated. Game feels unplayable thanks to the screwed up movement controls. As one moves left or right and holds the direction button, Shuggy accelerates instead of moving at constant speed. And in this game, where you need to maneuver precisely to avoid being killed (which means a level restart!) it is a game breaker. By the way,
jumping doesn't feel comfortable either...

Anyone knows how to fix this? Or can defend the game? Because else, I will put this as a review for the game and give it one star.
I feel really disappointed with this game and spending my money on it .
I can't speak for gamepad controls, but I had no issues with keyboard controls. I found that Shuggy's speed was easily regulated, and I rarely used his "full throttle" sprint. I'd agree his jumping wasn't the smoothest, but it never actually became a problem.
I've tried on keyboard. It works the same way. :/
All in all, the game feels too much like old hardcore stuff from times of C64 which is not of my liking really.
Good to hear that there are still people who enjoy this kind of thing, but, unfortunately, that no longer would be me...
Post edited January 09, 2014 by inc09nito
I have no problemas with it. I also find Shuggy movements a bit sluggish, and I'd like it to move a bit faster.
Playing this one on a keyboard seems too rough to me. It's a console-ish game.
Gave Shuggy a helluvah go some 4 years ago and it's a great game, addictive as heck and I can't say a bad thing about it.

On the other hand, Gateways is a completely different deal. Frustrating and hard as balls (imho) I decided to quit it; but the memory of my personal joy with this game still remains. Yup, I lost the save, too, so there's that ;(
Post edited January 19, 2017 by vicklemos