It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Oh well, I just removed all compatibility options and now the music works ! Either with Virtualmidisynth or Bassmidi.
Hope the absence of these compat settings won't lead to annoying consequences.
I'm currently trying to get Overseer (steam version) in a playable state. It actually is (having messed with a dgVoodo wrapper at http://dege.freeweb.hu/ and installed ffdshow and some RSXS dll sound thing), but I just thought I could get rid of that "error code does not indicate an errer" error message, and maybe have better midi as a bonus while I'm at it. That was not to be, but whatever. I think I can work with what I got without this.

"very, very easy."

Riight. Lured me right in. I should have known NOT to try this just from that! :p

"Run the Coolsoft configurator program and install the soundfont(s) of your choice (very, very easy.) On the Midi Mapper tab, look at the "Windows Media Player default device" menu and make sure that "Coolsoft VirtualMidiSynth" is the device selected. "

I'm sure that's very nice, if only the "Coolsoft VirtualMidiSynth" would actually APPEAR in that drop-down menu (and I AM using the (not so) Coolsoft VirtualMIDISynth configurator here). Instead there are only two entries:
- VirtualMIDISynth #1
- Microsoft GS Wavetable Synth

Sure enough a couple of the soundfonts I tried didn't work either (FatBoy-v0.784.sf2 and Arachno SoundFont - Version 1.0.sf2. Didn't get any error on FluidR3_GM.SF2, but still no go). Probably related to no coolsoft virtualmidisynth in that list, but I give up.

Sure, this is an old thread and all that. And I do appreciate the pointers to get an old game going even if it didn't work out for me. Using Windows 7 64 bit btw.
Post edited January 12, 2019 by coilwinder