It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Oh well, I just removed all compatibility options and now the music works ! Either with Virtualmidisynth or Bassmidi.
Hope the absence of these compat settings won't lead to annoying consequences.
I'm currently trying to get Overseer (steam version) in a playable state. It actually is (having messed with a dgVoodo wrapper at http://dege.freeweb.hu/ and installed ffdshow and some RSXS dll sound thing), but I just thought I could get rid of that "error code does not indicate an errer" error message, and maybe have better midi as a bonus while I'm at it. That was not to be, but whatever. I think I can work with what I got without this.

"very, very easy."

Riight. Lured me right in. I should have known NOT to try this just from that! :p

"Run the Coolsoft configurator program and install the soundfont(s) of your choice (very, very easy.) On the Midi Mapper tab, look at the "Windows Media Player default device" menu and make sure that "Coolsoft VirtualMidiSynth" is the device selected. "

I'm sure that's very nice, if only the "Coolsoft VirtualMidiSynth" would actually APPEAR in that drop-down menu (and I AM using the (not so) Coolsoft VirtualMIDISynth configurator here). Instead there are only two entries:
- VirtualMIDISynth #1
- Microsoft GS Wavetable Synth

Sure enough a couple of the soundfonts I tried didn't work either (FatBoy-v0.784.sf2 and Arachno SoundFont - Version 1.0.sf2. Didn't get any error on FluidR3_GM.SF2, but still no go). Probably related to no coolsoft virtualmidisynth in that list, but I give up.

Sure, this is an old thread and all that. And I do appreciate the pointers to get an old game going even if it didn't work out for me. Using Windows 7 64 bit btw.
Post edited January 12, 2019 by coilwinder
avatar
coilwinder: I'm currently trying to get Overseer (steam version) in a playable state. It actually is (having messed with a dgVoodo wrapper at http://dege.freeweb.hu/ and installed ffdshow and some RSXS dll sound thing), but I just thought I could get rid of that "error code does not indicate an errer" error message, and maybe have better midi as a bonus while I'm at it. That was not to be, but whatever. I think I can work with what I got without this.

"very, very easy."

Riight. Lured me right in. I should have known NOT to try this just from that! :p

"Run the Coolsoft configurator program and install the soundfont(s) of your choice (very, very easy.) On the Midi Mapper tab, look at the "Windows Media Player default device" menu and make sure that "Coolsoft VirtualMidiSynth" is the device selected. "

I'm sure that's very nice, if only the "Coolsoft VirtualMidiSynth" would actually APPEAR in that drop-down menu (and I AM using the (not so) Coolsoft VirtualMIDISynth configurator here). Instead there are only two entries:
- VirtualMIDISynth #1
- Microsoft GS Wavetable Synth

Sure enough a couple of the soundfonts I tried didn't work either (FatBoy-v0.784.sf2 and Arachno SoundFont - Version 1.0.sf2. Didn't get any error on FluidR3_GM.SF2, but still no go). Probably related to no coolsoft virtualmidisynth in that list, but I give up.

Sure, this is an old thread and all that. And I do appreciate the pointers to get an old game going even if it didn't work out for me. Using Windows 7 64 bit btw.
I just fired it up and sound and Midi music are working fine. Game is still working exactly as I described in the original years'-old post...;) Just tested it in Win10x64 version 1903, build 18334 (an advanced Insider's build) , still running fine--but I am running the GOG version of the DVD game version. Yes, you still have to write in Microsoft Midi Mapper and then select it from the in-game configuration as I wrote in the original post--selecting either coolsoft or virtualMidiSynth #1 ingame will not work. If you don't see "Microsoft Midi Mapper" in your in-game Midi config options, you haven't properly written it into your Tex .ini file--not an option, I'm afraid...;) Follow my instructions to the letter on that point.

BUT...this may be your problem...open up your Coolsoft Virtual MidiSynth configuration (you should have the Coolsoft icon in your systray and it should be running)--right click it and select the "Options" tab, and check the box for "Output audio device" and make sure it's set to the device you use for sound. For instance, I have a sound port coming from my AMD GPU and also a sound port coming from my RealTek 1250--if you have the VirtualMidiSynth config set to the wrong sound device---guess what?--you won't hear any midi in the game, just as you have described. So make sure that not only is the CoolsoftVMS MidiMapper tab set in both places for VirtualMidiSynth#1, but then in the "Options" tab you have selected the correct sound device!

I am running the GOG version of the DVD game version. You may not have noticed, but Steam generally doesn't bother to update the older game software its sells--GOG does a good job of staying on top of it and keeping older games running on newer OSes--don't know why Steam believes this to be unimportant, but I've seen this more than once. So I cannot speak as to whether these instructions will work with the Steam version, although I cannot see why they would not.

Hope this helps--but these instructions work with Win7/8/and 10, and I've verified them myself. Good luck!
Post edited February 17, 2019 by waltc
avatar
Wronschien: Oh well, I just removed all compatibility options and now the music works ! Either with Virtualmidisynth or Bassmidi.
Hope the absence of these compat settings won't lead to annoying consequences.
It hasn't for me--indeed, the only compatibility options I use (Win10x64) are run as admin and the application scaling option! No problems, glad to say.