It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have all eldritch tokens in all four planes and supposedly a Dreamlands 2 should appear after beating Dreamland's final level. I did that twice, once even with all eldritch tokens in my bag, but it doesn't appear.

I am playing the Linux port. I hope that it is up-to-date on GOG.
This question / problem has been solved by Shadowcatimage
I think I was seeing the same thing as you -- the "Planes" menu shows only four options, ending with "Dreamlands I".

Despite the fact that I had been working my way through Dreamlands 2, 3, and 4 in sequence (being taken automatically to the next after finishing any one of them), it really looked as if there would be no way to jump back to the higher planes if you inadvertently returned to a lower one, because nothing beyond "Dreamlands I" was visible.

I only discovered by accident, after something *did* reset me to a lower plane, that I could scroll the list with the up and down arrow keys.

So give that a try -- "Dreamlands II" might just be a keypress away.
Yeah, the devs told me that back then in May, well actually to use the mouse wheel. Unfortunately my mouse wheel was broken and only worked occasionaly, so I didn't notice that function by accident but after the hint, good to know that the arrow keys work as well.
Cool. That would have been a good time to answer your own question here, in order to help others find that solution. I think you should be able to mark this question as solved?
Yeah well, I tend to forget about topics that never got a reply (which are quite a few), else I would have written that here.
I guess this tells us that the developers have absolutely no presence whatsoever here on this forum, which is a bit disappointing (but I'm happy to have the games here regardless).