It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So, has anyone else seen this?--

System.ObjectDisposedException: Cannot access a disposed object.
Object Name: name
at System.Windows.Forms.Control.CreateHandle()
at System.Windows.file .CreateHandle()
at System.Windows.Forms.Control.get_Handle()
at System.Windows.Forms.Control.GetSafeHandle(IWin32Window window)
at System.Windows.Forms.MessageBox.ShowCore(IWin32Window owner, String text, String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options, Boolean showHelp)
at file .Framework.WindowsGameHost.ShowMissingRequirementM essage(Exception exception)
at file .file .ShowMissingRequirementMessage(Exception exception)
at file .file .RunGame(Boolean useBlockingRun)
at Terraria.file (String[] args)

Things were fine for the first few days, and then this happens. I'm happily constructing my mahogany-and-tin jungle bunker, when, without warning, my computer starts running hot and shuts down. When I turn it back on, I see the above message. Since then, I haven't gotten more than half an hour at a time out of the game before it poops itself and gives me that same error.

I've fiddled with settings, reinstalled the game, and cleaned my computer: nothing works. I'm off to reinstall my XNA and .NET Frameworks, per the most recent advice I've found.

Any other suggestions? Should I just wait until v1.3 fixes things?
No posts in this topic were marked as the solution yet. If you can help, add your reply
How do other games react when you play them for longer periods of time? If they also cause issues then it's probably a hardware problem. If they don't cause issues then XNA & .Net are likely to be be the culprits.
Other games play fine. This isn't a super-high-end machine or anything, but I've never had an overheat problem before--not on this machine, anyway. And I certainly have never seen an error like this before.

I tried reinstalling the Frameworks too. No love. Got fifteen minutes of a ditch dug before everything died. Again.

I take it you personally haven't seen this message. I ask because I've had a devil of a time hunting it up. I only found one thread on it in the Terraria forums, and it's been dead since 2011.
Post edited June 04, 2015 by UncleOvid
I haven't heard of Terraria crapping out like that if there wasn't some issue with the machine being played on, hard- and/or software. Have you tried to redownload Terraria and then reinstall?

If the exception (+ stack trace) it throws at you is correct, then Terraria is trying to access a message window that has been disposed for some reason. But it's apparently trying to access it due to something missing that the game wants to tell you about.

It's unlikely that 1.3 will fix this issue. If redownloading Terraria and reinstalling doesn't fix it, you may want to try posting on the official PC tech support forum:
Huh. According to the Terraria forums, this is some mysterious Steam-related affliction. Except... I don't have Steam. Never have. Or it's your standard antivirus conflict and/or corrupted installation. And, being a veteran PC gamer, and thus well-versed in the AV Check-Reinstall-Restart dance, I checked that stuff too, which, as ever, didn't seem to be the problem.

So I tried something out of left field: Deciding I'd check my CPU/RAM usage, I ran Terraria windowed instead of full screen as I've been doing. I've had it up for an hour now with no problems, and with CPU/RAM numbers staying well inside normal ranges. Doesn't make any sense to me, but I'm running with it.

I'm inclined to believe you that this probably isn't going to be a 1.3 fix, but since I haven't heard anything at all about bug fixes in the new version, I'm holding out hope. In the meantime, I'll keep running it windowed and see what happens.