It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Cheers for the note. I don't see a changelog, but maybe they just fixed the errors with the installer.

After some problems getting the game to run (see above) and issues with screen resolution and mouse not working properly, the game now runs well. Don't know how it got sorted really, because the game behaved a little different each time it started up, until it now launches with the re-logic logo filling the whole screen, instead of the top left corner as before. Whatever it is, it works now, so then all is well.

(I even got a reply to the support ticket, though by then things worked, thanks to the post up above here about being messy).

Personally I'm on Linux Mint, and very pleased with how it performs, and how stable it is compared with Windows. Extra bonus: I can control my own bloody system, and it won't randomly restart or install updates, nor spy on me (concerns about that is why Ubuntu itself will never appear on my computer).