It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Having a few issues with Terra Nil - mainly with the recycling drone. It gets stuck everywhere - even at the side of the airship. Most of the time it displays the round red and black "pound lock needed" icon above it. To get it to move I have to click on the top of the drone with the blue square and then tap on the next tile I want it to go to. And it is s-l-o-w (and choosing 2x or 3x makes it stop completely). If I log out and then log back in it will move on it's own a couple of tiles or I will find it back at the airship.
Logged out last night with only two silos to collect (maybe 96% reclaimed) and the button in the upper left showed zero animals introduced - while the Handbook showed 6/6. Had to exit the game and of course lost that whole map. I should point out that it was not possible to reintroduce the wildlife as I tried.
btw - having problems with zooming.
If someone could help me with the following issue it would be awesome: I am also having problems setting up my displays. I have two screens, one 24" and one 36". The game that I usually play (and have played for many years) allows me to use Discord or whatever or a paint program or even another instance of it or another game on the second, smaller display. When doing things like crafting I run two characters simultaneously - one on one screen and one on the other. With TN as soon as I click on a button on the large display it monopolizes the cursor and I can't drag it to the other screen.
Another HUGE problem with the game - and a patch is needed to fix it - is those damn "1 of 6" labels showing how many structures a turbine was supporting: they obliterate the landscape and structures underneath. Don't know why they did it that way when a pop-out tool tip would work (or you can always just count the power cables and save your sight and mind).
And... how do I go about uploading my avatar?
Thanks in advance -
No posts in this topic were marked as the solution yet. If you can help, add your reply