It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone

I've always wanted to try ToME but after playing the tutorial on the free version I decided to actually buy it to help the developers. I've bought the base game and the first expansion and now I was considering buying the Embers of Rage exp as well. Unfortunately, I found out that the GOG version does not work very well on my mac (I am sending my specs as an attached image). These problems happen on both Galaxy and by manually opening the "t-engine" file.

What happens is that the controls respond very badly, especially for movement. I have to press the numpad keys or arrows more than once to register, and sometimes it only works when I double or triple-press in very quick succession, sometimes resulting in a double movement. Considering this is a turn-based roguelike, I guess I don't need to emphasize how game-breaking this can be.

Furthermore, this also affects other commands such as pressing ESC to enter the menu or leaving a popup window. Clicking outside popup windows also very rarely close the window on the first try (and no, my mouse is not buggy or old, it works perfectly fine elsewhere).

As if this wasn't bothersome enough, it is impossible to just exit the game. Whether I try to exit in-game or from the main menu (the action of returning to the main menu works fine), the game crashes (after saving,at least) completely. It is impossible to take any action, including changing desktops or exiting full screen. In all tests I made, I was forced to hard-reboot my computer to be able to continue normal use. I changed to window mode and could see the following messages on the console, when entering through the "t-engine" file.

2018-05-18 15:42:18.680 t-engine[3760:141678] Internals of CFAllocator not known; out-of-memory failures via CFAllocator will not result in termination.
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
LaunchProcess: failed to execvp:
/Users/*****/Contents/Frameworks/t-engine Helper

Apparently these issues don't happen when using the standalone version from the te4 website, which is confusing. I've searched this forum for an answer and saw someone posting a similar issue, but found no answer that could help me.

I am very frustrated, because I bought the game through GOG, being my favorite platform for digitally buying and playing games, but now I've got an almost unplayable game (considering that the experience should be pleasant). I could have bought directly from the developer and be playing smoothly, but now there is no way to use my GOG purchase to unlock the premium version through Te4 and download the DLC's I've bought (as far as I know).

I really hope someone can help me

Kind Regards and thanks in advance!
macspecs.png (24 Kb)
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well, before anyone scolds me for not having tried it, YES, I found out that I could redeem my purchases with my serial keys. Now I am able do download the standalone versions from the TE4 website, and also YES, they work without the problems I had in the GOG version.

In other words, my problem of not being able to properly play the full premium game with DLCs is solved. Nevertheless, the problem of not being able to use the platform I bought the game for (GOG galaxy) is not. I hope some update can solve this. If there is a proper solution, I'd gladly return to Galaxy for playing the game.
lhlfonseca: Hello everyone...
I am having these same problems. I can't log in with my TOME account at all because the keys don't always register a press and my password is always messed up (it's lengthy). I turned off the overlay and it fixed an issue where the game minimizes on load, but that's about it. On Windows 10 I do not have any of these problems with TOME+GOG. I will try the stand-alone download to see if that solves my issues in OSX.