It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is there a mouse+WASD option enabled for Tachyon?

If not, how do you map it?
avatar
Madzack: Is there a mouse+WASD option enabled for Tachyon?

If not, how do you map it?
Those keys are used, but keyboard keys are used for strafing, rolling, "sliding", ect. You steer your ship with the mouse, and forward or backwards movement is controlled by keyboard (Thrust). Somewhat similar to Freelancer a bit, but a little more involved. I believe you can change keyboard commands to suit your tastes, but the WASD is not used to move forward or backwards, or right and left. Here's a pic of the controls, in the event you or someone else hasn't picked up the game yet, and want to know how it all works....

edit: Just fyi, you can remap buttons under options-->input remap * Also, in the event you have a joystick, it also has joystick support, although I haven't used it
Attachments:
Post edited January 13, 2017 by Zoltan999
Yea I'm having issues with the controls myself. the ships is on a constant spinning counter-clockwise
avatar
zgrillo2004: Yea I'm having issues with the controls myself. the ships is on a constant spinning counter-clockwise
Same here. I struggled to get my X52 flightstick working properly and then decided to play the game with keyboard + mouse. Now I have the constant spinning too.
avatar
zgrillo2004: Yea I'm having issues with the controls myself. the ships is on a constant spinning counter-clockwise
Not sure if this is your issue, but I was able to reproduce this problem by attempting to use the nglide_cinfig.exe located in the Tachyon game installation folder. I used it to change my games resolution to 1920x1080 from the "By app (default)" setting that was already listed there to see if it made a difference. Well, it did. As soon as my ship launched from the starbase, it started the spin you are describing. I could stop it by right-clicking and using free-mode for the mouse steering, but as soon as I right clicked again to enter cursor/bore-sight mode, it started spinning again. I exited the game and went back to game installation folder, and used the nglide configuration app to put the resolution setting back to "By app (default)", and the game works fine again.

As I stated, this may or may not apply to your situation, but I would go to the game installation and check the nglide config app, and fool around with it for a bit...it might help.
avatar
G-Lord: spinning
^see above...help it may help you too
Post edited January 13, 2017 by Zoltan999
I messed around a bit with the nGlide options. I get fast spinning with 3840x2160 and 1920x1080. Setting 1280x720 eliminates spinning, but I can only turn left. The only option that works consistently so far is leaving everything on default.
avatar
G-Lord: I messed around a bit with the nGlide options. I get fast spinning with 3840x2160 and 1920x1080. Setting 1280x720 eliminates spinning, but I can only turn left. The only option that works consistently so far is leaving everything on default.
Pretty much the same here. For me, the game and graphics(have everything cranked up in the in-game options) are decent at default settings, so for so old a game on my Win10 machine, I am pretty happy with that
avatar
Zoltan999: Pretty much the same here. For me, the game and graphics(have everything cranked up in the in-game options) are decent at default settings, so for so old a game on my Win10 machine, I am pretty happy with that
Yeah, I guess I'll play it with the default resolution. Too bad though, it looks so crisp at 4k :P.
I've seen a few posts about the spinning issue on the nglide, Steam and WSGF forums, so it seems like a common issue. From what I can gather it is to do with how the game has hardcoded screen resolutions that must be setting up the mouse area, so when forcing other resolutions it does this incorrectly resulting in the mouse 0,0 co-ordinate being moved elsewhere, like the bottom right, which causes the spinning.

Some have reported that by Alt-Tabbing out of the game and then back in to the game resets the co-ordinates which fixes the issue, but it doesn't work (or isn't possible) for everyone to do this (I don't know why), so that might be worth a try.

Another option might be to try using dgVoodoo instead of nGlide, but as it is the game itself causing the issue I'd not expect this to be any different.
avatar
korell:
Can Confirm Alt-Tab works for me, however, this has to be done at the beginning of every single mission.

Default seems to be the best choice.