It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Has anyone managed to get it working? My 3D drivers seem to think it's all working but the game itself is flat as can be. The in-game crosshair is however rendered in 3D, but nothing else is. I'm definitely using the DX9 renderer, so I have no idea what the issue might be in this case.
I'm having the exact same problem! On the official nVidia 3D Vision forums, many users claim to have run this game in 3D Vision. I have no idea why this game won't render in 3D; only the lasersight works. Sucks :(
Oh, absolutely the same.

Even if I rename shock2.exe to thief3.exe or something that should work, there's no stereoscopy anyway (but the game starts working with one frame per ten seconds). But this trick helped with Deus Ex 1.
Well, it finally worked!! Here's the solution: systemshock . org / index.php?topic=4537
(I can't post links yet)

The only problem is that in 3d-mode you won't see hud icons like "security alert", "psi-boost bar".

Here's a short version of the guide written my a systemshock-org member Epyon:

1. Download the latest iZ3D driver, version Release Candidate 1.13.

2. Custom installation, pick only "D3D 8&9 Driver - iZ3D Monitor (free)", unselect other options.

3. Copy shock2.exe to thief3.exe, select "run as administrator" (if your UAC is on) and "disable display scaling on high dpi settings" in properties, compatibility tab. If you want to launch the mod-manager, create a shortcut to "thief3.exe -fm".

4. Make sure your nvidia 3d driver is installed and working, 3d-stereo mode is enabled or could be turned on by a hot-key (usually Ctrl-T). Now run the iZ3D Driver panel, select "Advanced" options, then uncheck everything in "in-game settings", and I HIGHLY recommend you to change the hotkeys at least to presets to something less simple than just Num 7, 8, 9.

5. In "status & method" check "enable stereo at application startup", but press "enable driver" only when you're going to play SS2! If you don't play DISABLE the driver! My recommendation - I had so many problems with that!

6. Run the game by executing thief3.exe or with your shortcut. The game looks AWESOME in stereo!

Also I couldn't play in 3d for so long because I've changed some settings in cam_ext.cfg. When I restored it to the original state (having changed only resolution list settings) I could play in stereo-3d.

We had a co-op walkthrough with my bro in Ponterbee Station fan mod, both in 3d. I've been waiting for this moment since 1999!