It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Heya. I have this weird problem with the multiplayer of System Shock 2. I've used both Tunngle and Hamachi plenty before successfully with other games, but we can't get the multiplayer to work. Portforwarding didn't do much either, mostly cause i'm not very tech oriented..

The client just gets a "Join failed" message no matter what, we even tried completely turning off our firewalls and cutting off our internet connections, then connecting the computers through a router or with a direct cable connecting with no luck. This REALLY should have worked.

The only reason for this behaviour, that I can come up with, is that the GOG version has a fubar multiplayer. Yes, I have read the FAQ's and multiplayer how-to's and I have played the multiplayer before with a non-GOG version. Tho' not with my current computer, so that's gonna be my next step to get a non-GOG version and have a go with that. But seriously, what is up with this? Single player works just fine.

Love the game anyways, best memories of my kidhood includes strolling in the corridors of Von Braun and suddenly *CLONK* "RRAAAARGH", a lead pipe to the back of my head..
Post edited March 16, 2013 by Kestaa
No posts in this topic were marked as the solution yet. If you can help, add your reply
Nevermind.. It was a case of wrong versions. 2.4 and 2.41 :P