It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi!

The 2.4 fan patch, as included in GOG's version of SS2, has a couple of attributes that are noteworthy for those of us who dislike any input lag, or the sensation thereof.
**EDIT** This also addresses the hypersensitive y-axis, for reasons currently unknown. Probably related to the game doing input calculations based on the frame rate, or something along those lines.

It mostly has great defaults, but this might be worth trying even if you think it's already perfect :) All of these changes are done in cam_ext.cfg.

1) Enable fps independent physics by uncommenting (removing the semicolon) this line.
phys_freq 60

2) Disable vsync with by uncommenting this line:
vsync_mode 0

3) Make sure the framerate cap IS commented, like so:
;framerate_cap 60.0

Setting these three variables like this has made the game much more enjoyable for me and several friends, give it a shot.

Disclaimer: Some people are really sensitive to image tearing, so ymmv.
Disclaimer 2: I didn't find a mention of this in the GOG forum by googling. If the topic has been chewed to death already, I'm sorry.

Bonus: If you have large monitor with a modern resolution, try uncommenting:
d3d_disp_scaled_2d_overlay 64
which will make the hud larger and crisp.
Post edited April 01, 2013 by mrfz
One thread it has been discussed in is this:

http://www.gog.com/forum/system_shock_2/advanced_graphical_options_guide

And also on systemshock.org in spots. I haven't played with some of those other options you described though. It seems I have framerate cap set to 100 by default, and I think vsync enabled through my graphics card. Did you notice a big difference using the phys_freq instead of vsync? Do you use a faster refresh rate? The comments seem to suggest vsync is preferable most of the time.
avatar
Boilpoint: One thread it has been discussed in is this:

http://www.gog.com/forum/system_shock_2/advanced_graphical_options_guide

And also on systemshock.org in spots. I haven't played with some of those other options you described though. It seems I have framerate cap set to 100 by default, and I think vsync enabled through my graphics card. Did you notice a big difference using the phys_freq instead of vsync? Do you use a faster refresh rate? The comments seem to suggest vsync is preferable most of the time.
Thanks for linking the thread!

The settings I mentioned are explicitly about disabling vsync in order to get rid of "floaty" controls, the hallmark of many vsync implementations.

With the Dark engine, this usually results in the game running too fast since the frame rate isn't limited by the vertical synchronization. However, setting "phys_freq 60" locks the game's internal framerate to 60, while letting the GPU draw how many frames it likes. Modern hardware usually maintains a very high frame rate in SS2 (seems to be locked to 250) which does away with visible tear lines.

To answer your question, I use a run-of-the-mill 60hz TFT. Tight mouse control vs tear-free vsync is a matter of personal preference. However, the phys_freq method gets you the best of both worlds: no visible tearing and no input lag. (Provided vsync really IS off, ie. not forced on in the GPU driver.)
Post edited April 01, 2013 by mrfz