It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey, I just got the MAC version of this game and there are two major issues with the game. First, all the particle effects and some lighting appear as giant white boxes and second the character skill screen (when in use mode press the cross thing at the bottom) doesnt appear, I click it and get nothing, not even a box telling me its there. Are there any solutions to these problem?

Oh when System Shock 2 was starting up it asked me to allow Winskinx11, now by default I deny these things, would it help if I allowed this application through my firewall?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Why do so many people shorten "Macintosh" to "MAC"? Do they think it's an acronym? Are they getting confused with the MAC address of their network card? Well these are Mac users after all...
what puzzles me even more is that someone would actually want to use them for gaming.

anyway, to add some value to this post, it looks like either your gpu driver and/or windows api translation layer needs to be updated and/or settings modified. no idea how these things work on macs, only seen one once I believe.
Post edited June 23, 2013 by voodoo47
A Mac is as good for gaming as any computer with the same hardware. They suck for anything modern, but they are fine for old games.

Anyway, back to the original question: What you are experiencing sounds like driver problems with Wine. What OS do you have and what graphics card? Intel cards are know to be problematic when it comes to Wine. Allowing Wineskin X11 to access the internet won't make any difference, it just asks that question in case you' want to use online multiplayer or some download functionality.
After facing the same texture transparency issue on my own machine with MacOS 10.6.8 and an ATI card I have dug around to look for solutions and found that forcing 'Windowed Mode' in the game's configuration files should take care of the transparency problem.

You can do that by editing the following file in TextEdit:

/Applications/System Shock 2.app/Contents/Resources/drive_c/GOG Games/System Shock 2/cam_ext.cfg

and enabling forced windowed mode by searching for ' ;forced windowed " and removing the semicolon.

If you are not sure of how to enter the System Shock 2.app folder, you can do so by going to your Applications folder, looking up System Shock 2, right clicking it and then selecting "Show Package Contents".

Once you get into Windowed mode, try to increase the resolution and restart the game -before- actually starting to play. I have found that changing the resolution in Forced Windowed mode causes the game to ignore your key binds until you restart. Annoyingly this also includes the ESC key to go back to the game menu.

Hope this helps!
Thank you, I shall try these suggestions out and get back to you with the results.