It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi Everybody,

I've been running SS2 for about 6 hours total over the course of two weeks with no problems. Well, some, it will occasionally randomly quit on me but I've got an older computer that isn't really geared for gaming, plus WINE can be kinda unstable anyway. Anyway, now when I click the icon it bounces/blinks but the game itself doesn't load. Normally the screen goes to maximum gamma and hangs for a second before the game starts but that isn't happening either. :( Most frustrating. I'm playing the unmodded version straight from GOG.com (maybe I am missing a patch?). I tried renaming the shock2.exe file since I read that might help, but no dice.

Here are the specs:

Mac OS X 10.9.1
Processor: 2.4 Ghz intel core 2 duo
Memory: 4GB 1067 Mhz DDR3

If you need anything else, let me know.
This question / problem has been solved by lpjrimage
avatar
xunzian: ...
Common graphic fixes include this:

Edit cam_cfg inside the game's folder:
- Set a semicolon before multisampletype 8 like this
;multisampletype 8

- Remove the semicolon before d3d_disp_no_rgb10_buf like this
d3d_disp_no_rgb10_buf

- Run the game in the same resolution as your desktop

To check whether the issue is game and not system related, you can backup your saves and remove and re-install the game. Check if it now works out-of-the-box as it did after your last install.
Post edited January 14, 2014 by DeMignon
those should not make the game crash. anyway, there should be a crash.dmp and shock2.log in your SS2 folder, zip those up, upload somewhere, and post the link.
avatar
voodoo47: those should not make the game crash. anyway, there should be a crash.dmp and shock2.log in your SS2 folder, zip those up, upload somewhere, and post the link.
Good to have you on this thread voodoo47. I was just about to tell xunzian to ask you. ;-)
Cheers
I tried copying the shock2.log but it is too big (?) for gog. Where would be a good site to upload them?
I'm using sendspace for most of my temp stuff. don't forget the crash.dmp as well.
OK, so I created an account at sendspace but the "drag and drop" feature doesn't seem to work and since I am using a mac I can't see the individual files when I used the "browse" option. Sorry, I'm really bad with macs.

Thanks for all the help and the patience, you guys rock!
Post edited January 18, 2014 by xunzian
you don't need to create an account, you just click "browse" on the main page and point it to the zip file.
Try this:

Go to applications folder --> Right click System Shock 2 --> Show package contents.
Double click Wineskin --> Advanced --> Test run.
avatar
xunzian: Hi Everybody,

I've been running SS2 for about 6 hours total over the course of two weeks with no problems. Well, some, it will occasionally randomly quit on me but I've got an older computer that isn't really geared for gaming, plus WINE can be kinda unstable anyway. Anyway, now when I click the icon it bounces/blinks but the game itself doesn't load. Normally the screen goes to maximum gamma and hangs for a second before the game starts but that isn't happening either. :( Most frustrating. I'm playing the unmodded version straight from GOG.com (maybe I am missing a patch?). I tried renaming the shock2.exe file since I read that might help, but no dice.

Here are the specs:

Mac OS X 10.9.1
Processor: 2.4 Ghz intel core 2 duo
Memory: 4GB 1067 Mhz DDR3

If you need anything else, let me know.
I have this same problem with 10.10.2. Were you ever able to find a solution?